Windows 2000 stops responding to SMB requests and to RPC requests when you try to encrypt a file on a Windows 2000-based domain controller (895266)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you try to encrypt a file on a Microsoft Windows 2000-based domain controller, Windows 2000 stops responding to server message block (SMB) requests from the client computer. Additionally, Windows 2000 stops responding to remote procedure call (RPC) requests from the client computer.

This symptom occurs if the following conditions are true:
  • You try to encrypt the file by using local computer policy or domain policy.
  • The Windows 2000-based domain controller has Encrypting File System (EFS) disabled.
Additionally, an error message that is similar to the following is logged in the System log:Event Type: Error
Event Source: Active Directory
Event Category: None
Event ID: 1188
User: N/A
Computer: <servername>
Description: A thread in the directory is waiting in a remote procedure call (RPC) to directory <directory> performing a(n) <operation name> operation. The directory has attempted to cancel the call and recover thread id <thread id>. If this condition persists, stop and restart that Windows Domain Controller. Note When this problem occurs, you can still successfully ping the client computer from the Windows 2000-based domain controller.

CAUSE

This problem occurs because of a chain deadlock in the kernel-mode driver for the Distributed File System (DFS) client functionality.

Note The chain deadlock occurs between the Dfssvc.exe system process and the Lsass.exe system process.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Windows 2000 Service Pack 4 (SP4) before you apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size  File name
   ----------------------------------------------------
   08-Mar-2005  19:54  5.0.2195.7035  90,544  Mup.sys

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about how to disable EFS for all computers in a Windows 2000-based domain, click the following article number to view the article in the Microsoft Knowledge Base:

222022 How to disable EFS for all computers in a Windows 2000-based domain

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kberrmsg kbPerformance kbBug kbfix kbpubtypekc KB895266 kbAudITPRO