You may receive a blank page when your browser submits a POST request to an ASP Web page through ISA Server 2004 (895202)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition
  • Microsoft Internet Security and Acceleration Server 2004, Enterprise Edition

SYMPTOMS

When your browser submits a POST request to an Active Server Pages (ASP) Web page through Microsoft Internet Security and Acceleration (ISA) Server 2004, you may receive a blank page in response.

CAUSE

This problem may occur if the following conditions are true:
  • Your ISA Server 2004-based computer is configured with a Content-Type-based rule.
  • The Content-Type-based rule applies to HTTP traffic that is evaluated when the POST request is processed.
  • The POST request that is made by the client is an HTTP 1.1 request.
  • The Web server sends back an "HTTP 100 Continue" response before it sends the "HTTP 200" response together with the response data.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891024 How to obtain the latest ISA Server 2004 service pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Security and Acceleration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

ISA Server 2004, Standard EditionYou must have ISA Server 2004 Service Pack 1 installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891024 How to obtain the latest ISA Server 2004 service pack

ISA Server 2004, Enterprise EditionNo prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.ISA Server 2004, Standard Edition
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   01-Apr-2005  00:39  4.0.2163.252  647,440  w3filter.dll
ISA Server 2004, Enterprise Edition
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   02-Apr-2005  18:19  4.0.3440.252  663,320  W3filter.dll

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Security and Acceleration Server 2004. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

MORE INFORMATION

For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:

885957 How to install ISA Server hotfixes and updates

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

885957 How to install ISA Server hotfixes and updates


Modification Type:MinorLast Reviewed:10/12/2006
Keywords:kbISAServ2000preSP2fix kbfix kbbug kbHotfixServer KB895202 kbAudITPRO