When you install a Systems Management Server 2003 client on a virtual machine, the virtual machine does not appear in the Dell Updates collection (895157)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

You install a Microsoft Systems Management Server (SMS) 2003 client on a virtual machine that was installed on a Dell computer. (The virtual machine is created by using Microsoft Virtual PC or Microsoft Virtual Server.) You also install the Inventory Tool for Dell Update (ITDU) on the SMS 2003 site server. In this scenario, the virtual machine does not appear in the Dell Updates collection in the SMS Administrator Console.

Note This problem occurs even if you change the Collection limiting query on the General tab in Query Rule Properties from Limit to collection: Dell Updates (pre-production) to Not collection limited.

CAUSE

This problem occurs because hardware discovery identifies the computer model as a virtual machine instead of as a Dell computer. Therefore, the virtual machine that is created on a Dell computer will not be listed in the Dell Updates collection.

STATUS

This behavior is by design.

MORE INFORMATION

To see the Model option for the computer, follow these steps:
  1. Open the SMS Administrator Console.
  2. Expand Site Database (Site_code-Site_name), and then expand Collections.
  3. Click All Systems, right-click the Virtual PC or Virtual Server SMS client on the right pane, point to All Tasks, and then click Start Resource Explorer.
  4. Expand Hardware.
  5. Click Computer System. The Model column displays Virtual Machine.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbtshoot kbprb KB895157 kbAudITPRO