You are prompted two times for your logon credentials when you try to use the mstsc command together with the console switch in Remote Desktop for Administration (895117)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

Consider the following scenario: In Remote Desktop for Administration, you try to use the mstsc command together with the console switch to connect to a console session on a Microsoft Windows Server 2003-based computer. In this scenario, you are prompted two times for your logon credentials.

CAUSE

This problem occurs because of a synchronization error in the Winlogon service. The Winlogon service handles synchronization between the temporary session and the console session in Windows Server 2003. If the temporary session and the console session are not synchronized, the Winlogon service may not log on correctly. When this problem occurs, you are prompted again for your logon credentials.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix file information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   08-Mar-2005  17:25  5.2.3790.284  380,928  Licdll.dll
   08-Mar-2005  17:16  5.2.3790.284  540,672  Winlogon.exe

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.
This bug was corrected in Microsoft Windows Server 2003 Service Pack 1 (SP1).

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix KB895117 kbAudITPRO