The Forgotten Password Wizard incorrectly backs up your password to drive C, or you receive a "This disk is not a password reset disk" error message when you try to use the Password Reset Wizard to reset your password in Windows XP (894686)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You may experience one or both of the following symptoms in Microsoft Windows XP:
  • When you use the Forgotten Password Wizard to create a password reset disk, the wizard incorrectly backs up your password to drive C instead of to removable media.
  • When you try to use the Password Reset Wizard to reset your password, you receive the following error message:
    File Not Found
    This disk is not a password reset disk.
    Therefore, you cannot reset your password.

CAUSE

This problem occurs because of a problem in the Windows Stored User Names and Passwords component (Keymgr.dll). If an error occurs when you select a drive in the Forgotten Password Wizard or the Password Reset Wizard, Keymgr.dll may select the first available drive letter as the drive. You may experience this problem if one or more of the following conditions are true:
  • One removable disk drive is connected to the computer, but no floppy disk drives are installed or connected to the computer.

    Note This removable disk drive may be a storage device that is connected to a universal serial bus (USB) port or to an IEEE 1394 (Firewire) port.
  • More than one removable disk drive is connected to the computer, no floppy disk drives are installed or connected to the computer, and an error occurs when you select the correct removable drive in the Forgotten Password Wizard. You may experience an error in the Forgotten Password Wizard if one of the following conditions is true:
    • You have not applied the hotfix that is mentioned in the following Microsoft Knowledge Base (KB) article:

      894685 Removable devices may not appear when you use the Forgotten Password Wizard or the Password Reset Wizard in Windows XP

    • In the Forgotten Password Wizard, you manually enter the drive letter or the drive description. You do not select one of the listed removable drives.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Note We recommend that you also install the hotfix that is mentioned in the following Knowledge Base article:

894685 Removable devices may not appear when you use the Forgotten Password Wizard or the Password Reset Wizard in Windows XP

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   26-Apr-2005  06:16  5.1.2600.2663  150,528  Keymgr.dll

WORKAROUND

You may be able to work around this problem by following the steps in the "Workaround" section of the following Microsoft Knowledge Base article:

894685 Removable devices may not appear when you use the Forgotten Password Wizard or the Password Reset Wizard in Windows XP

Note If only one removable disk drive is connected to the computer, connect an additional removable disk drive. Then, follow the steps in Microsoft Knowledge Base article 894685.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

306214 How to create and use a password reset disk for a computer in a domain in Windows XP

305478 How to create and use a password reset disk for a computer that is not a domain member in Windows XP


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbbug KB894686 kbAudEndUser kbAudITPRO