You receive the "No gps receiver is detected" message when you try to use the Configure GPS Receiver command in Streets and Trip (894511)



The information in this article applies to:

  • Microsoft Autoroute 2007
  • Microsoft Autoroute 2007 (with GPS)
  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft Streets & Trips 2007
  • Microsoft Streets & Trips 2007 (with GPS)
  • Microsoft Streets & Trips 2006
  • Microsoft Streets & Trips 2005

SYMPTOMS

When you try to use the Configure GPS Receiver command in Microsoft Streets and Trips, you receive the following message:No gps receiver is detected. Make sure that the gps is plugged into the communication (COM) port on your computer and no other program is using it.This message may appear even if you have a GPS device plugged into your computer.

CAUSE

This issue may occur because of one of the following reasons:
  • You plug the GPS device into your computer before you install Streets and Trips.
  • The driver for the GPS device is not installed correctly.
  • The COM port that the GPS device is trying to use is being used by another device.
  • The COM port that the GPS device is trying to use is being blocked by another program.

RESOLUTION

To resolve this issue, you must determine the cause of the issue on your computer. To do this, use the following methods in the order that they appear in.

Method 1

Install Streets and Trips before you connect the GPS device to your computer. To configure your GPS device correctly, follow these steps:
  1. Follow the instructions that are provided with Streets and Trips to install the program.
  2. Restart your computer.
  3. Plug the GPS cable into the COM port on the back of your computer.
  4. Plug the GPS cable into the locator receiver. The blue light on the GPS Locator indicates that the receiver is connected correctly.
  5. Start Streets and Trips.
  6. On the Tools menu, point to GPS, and then click Configure GPS Receiver.
  7. In the Available ports list, all the available com ports are listed. Click Scan. The GPS device is listed in the Available ports list as Communications Port (COM xx) - Microsoft GPS device found.
  8. In the GPS Pane, click Track Position.
The GPS device starts to initialize. If the GPS device is not detected, go to Method 2.

Method 2

If you complete the steps in Method 1 and the GPS device is not detected, follow these steps:
  1. Close Streets and Trips.
  2. Verify that the GPS cable is connected to the receiver and the computer.
  3. Click Start, click Run, type devmgmt.msc, and then click OK to start Device Manager.
  4. In Device Manager, expand Ports (COM & LPT), and then verify that Microsoft USB GPS Port is listed.

    If Microsoft USB GPS Port is not listed, but Other Devices is listed, the driver for the GPS device is either not installed or is not installed correctly. To install the driver, follow these steps:
    1. Right-click Other Devices, and then click Update Driver.
    2. On the Welcome to the Hardware Update Wizard page, click No, not this time, and then click Next.
    3. Click Install from a list or specific location, and then click Next.
    4. Click Don't search. I will choose the driver to install, and then click Next.
    5. Click Have Disk, and put the Streets and Trips installation CD in your computer's CD drive.
    6. In the Copy manufacturer's files from box, type the following path of the driver files :

      CD_Drive_Letter:\GPSDRVRS\Operating_System\

    7. Click OK, and then click Next.
    8. Follow the steps in the wizard to finish the installation.
    If Microsoft USB GPS Port or Other Devices is not listed in Ports (COM & LPT), go to Method 4.
  5. Start Streets and Trips.
  6. On the Tools menu, point to GPS, and then click Configure GPS Receiver.
  7. In the Available ports list, all the available com ports are listed. Click Scan. The GPS device is listed in the Available ports list as Communications Port (COM xx) - Microsoft GPS device found.
  8. In the GPS Pane, click Track Position.
The GPS device starts to initialize. If the GPS device is not detected, go to Method 3.

Method 3

If you have completed Method 1 and Method 2, and the GPS device is not detected, follow these steps:
  1. Close Streets & Trips.
  2. Verify that the GPS cable is connected to the receiver and the computer.
  3. Click Start, click Run, type devmgmt.msc, and then click OK to start Device Manager.
  4. Examine the computer configuration to find another hardware device that may be using a com port. If another hardware device uses a com port, note the hardware device.
  5. Switch the GPS Port to a different com port. To do this, follow these steps:
    1. Right-click the port that is configured for the GPS, and then click Properties.
    2. Click the Port Settings tab, and then click Advanced.
    3. Click Defaults, and then click OK.
  6. Restart your computer.
  7. Start Streets and Trips.
  8. On the Tools menu, point to GPS, and then click Configure GPS Receiver.
  9. In the Available ports list, all the available com ports are listed. Click Scan. The GPS device is listed in the Available ports list as Communications Port (COM xx) - Microsoft GPS device found.
  10. In the GPS Pane, click Track Position.
The GPS device starts to initialize. If the GPS device is not detected, go to Method 4.

Method 4

  1. Close Streets and Trips.
  2. Verify that the GPS cable is connected to the receiver and the computer.
  3. Contact the manufacturer of your GPS device and obtain the latest driver for your device.

    For information about how to contact the manufacturer of your GPS device, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

    65416 Hardware and software vendor contact information, A-K

    60781 Hardware and software vendor contact information, L-P

    60782 Hardware and software vendor contact information, Q-Z

    Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
  4. Follow the manufacturer's directions to install the driver for your GPS device.
  5. Restart your computer.
  6. Click Start, click Run, type devmgmt.msc, and then click OK to start Device Manager.
  7. In Device Manager, expand Ports (COM & LPT), and then verify that Microsoft USB GPS Port is listed.
  8. If Microsoft USB GPS Port is not listed, go to Method 5.
  9. If Microsoft USB GPS Port is listed, follow these steps:
    1. Start Streets and Trips.
    2. On the Tools menu, point to GPS, and then click Configure GPS Receiver.
    3. In the Available ports list, all the available com ports are listed. Click Scan. The GPS device is listed in the Available ports list as Communications Port (COM xx) - Microsoft GPS device found.
    4. In the GPS Pane, click Track Position.
The GPS device starts to initialize.

Method 5

If Microsoft USB GPS Port is not listed in Ports (COM & LPT) after you complete Method 4, use one of the following methods to troubleshoot the issue:
  • A terminate and stay resident program (TSR) maybe be blocking the detection of the GPS device. Perform a clean boot procedure on your computer.

    For more information about how to perform a clean boot procedure, click the following article number to view the article in the Microsoft Knowledge Base:

    267288 How to perform a clean boot in Windows Millennium Edition

  • Note the other hardware that is connected to the computer. Answer the following questions:
    • Has the GPS device worked before?
    • Has hardware or software been installed recently?
    • Has this issue occurred with other programs or hardware installations?
  • If it is possible, try to connect your GPS device to another computer that is running Streets and Trips. For example, if you are trying to connect your GPS device to a portable computer, install Streets and Trips and the GPS device on a desktop computer. If the GPS device cannot be detected on a different computer, you may have defective hardware. For example, the cable for the device may be defective, and may have to be replaced.

Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbtshoot kbprb KB894511 kbAudEndUser