A code 10 error occurs in Device Manager when you restart a Windows XP-based computer that is connected to an external 1394 device (894480)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

You start a Microsoft Windows XP Service Pack 1 (SP1)-based computer or a Windows XP Service Pack 2 (SP2)-based computer. Certain Institute of Electrical and Electronics Engineering (IEEE) 1394 devices such as a hard disk drive or a digital video (DV) camera are not correctly enumerated.

When this problem occurs, a code 10 error may occur in Device Manager for one or more of the plugged-in 1394 devices.

CAUSE

This problem occurs when the IEEE 1394 bus is reset. A bus reset is a regular occurrence on the 1394 bus and occurs every time that you plug or unplug a 1394 device.
During a bus reset, the IEEE 1394 bus is reinitialized, and all 1394 devices are reenumerated on the bus. In this case, the IEEE 1394 device may not be correctly enumerated.

Note A code 10 error indicates that the 1394 device did not start.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this fix requires Windows XP SP1 or Windows XP SP2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Apr-2005  13:39  5.1.2600.2650      43,264  Sbp2port.sys
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbbug KB894480 kbAudITPRO