You can take the MTA resource offline, but you cannot bring the MTA resource back online after you restart a Windows-based cluster (894094)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you restart a Microsoft Windows-based cluster that is running Microsoft Exchange Server 2003, the Exchange 2003 message transfer agent (MTA) resource starts successfully. However, when you follow these steps, the MTA resource may fail:
  1. You right-click the MTA resource, and then you click Take Offline.
  2. You right-click the MTA resource, and then you click Bring Online.
Additionally, the following event may be logged in the Application event log:Event ID: 3080
Event Type: Warning
Event Source: MSExchangeMTA
Event Category: Internal Processing
Description: A fatal MTA database server error was encountered.

CAUSE

This problem typically occurs after the MTA resource releases a lock too early on an object that is not thread safe. Data is then incorrectly written to the Db000001.dat file. If any valid pointers to MTA queues are incorrectly written, the MTA resource may not start successfully.

Note The Db000001.dat file is located in the Exchsrvr\Mtadata folder.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Exchange 2003 Service Pack 1 (SP1).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Feb-2005  22:32  6.5.7232.82     3,591,168  Emsmta.exe       
   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbExchange2003preSP1fix KB894094 kbAudITPRO