FIX: You experience an unexpected increase in memory usage when you deploy and enlist an orchestration in BizTalk Server 2004 (893754)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Service Pack 1

SYMPTOMS

In Microsoft BizTalk Server 2004, you experience an unexpected increase in memory usage by the Windows Management Instrumentation (WMI) provider process that hosts the Microsoft.Biztalk.ExplorerOM.dll file. This problem occurs when you deploy and enlist an orchestration.

You can use Windows Task Manager to see this increase in memory usage. To do this, follow these steps:
  1. Right-click the taskbar, and then click Task Manager.
  2. On the Process tab, examine the number in the Mem Usage column for the Wmiprvse.exe process.

CAUSE

This problem occurs because of a memory leak in the BizTalk WMI provider and in the BizTalk MetaData Management DLL.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have BizTalk Server 2004 Service Pack 1 (SP1) installed before you install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ----------------------------------------------------------------------------
   22-Dec-2004  19:16  3.0.5371.0  356,864  Btsmetadataom.dll 
   22-Dec-2004  19:18  3.0.5371.0  494,592  Btswmiprovider.dll 
   22-Dec-2004  19:44  3.0.5371.0  221,184  Microsoft.xlangs.biztalk.engine.dll


Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBTSOrchestration kbbug kbfix kbHotfixServer kbQFE KB893754 kbAudDeveloper kbAudITPRO