After you import contact records or lead records into Microsoft CRM by using the Import Wizard, a Create rule remains in a paused state or in a running state (893625)



The information in this article applies to:

  • Microsoft CRM 1.2

SYMPTOMS

In Microsoft Business Solutions CRM 1.2 Workflow, you may experience the following problem if you have a Create rule for contact records or for lead records. After you import contact records or lead records into Microsoft CRM by using the Import Wizard, the rule is not completed. When you view the rule in Workflow Monitor, the rule remains in a paused state or in a running state.

CAUSE

This problem occurs when the Create rule contains a Run Subprocess action, and you import contact records or lead records. When the Create rule contains a Run Subprocess action, DCOM cannot process the rule. This problem also causes the Microsoft CRM Workflow service to stop.

RESOLUTION

Microsoft CRM has a fix for this problem that is part of a cumulative update. The cumulative update information is described in the following Microsoft Knowledge Base article:

904435 Update Rollup 2 is available for Microsoft CRM 1.2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

Note You must create a Manual rule or a Create rule to reproduce this problem.

Create a Manual rule or a Create rule

  1. On the Microsoft CRM server, click Start, point to Programs, point to Microsoft CRM, and then click Workflow Manager.
  2. Type the name of the Microsoft CRM server in the Target Microsoft CRM Server box, and then click OK.
  3. In the Object box, click Lead. In the View box, keep the default value of Rule.
  4. Click File, and then click New.
  5. Use one of the following methods:
    • Follow these steps for a Manual rule:
      1. In the Create a Workflow Rule dialog box, type Lead Manual Rule in the Rule name box.
      2. In the Select the event box, click Manual, and then click Next.
      3. In the Select Behavior dialog box, click Insert Action, and then click Create Note.
      4. Type Manual Lead Note in the Subject box, and then click OK.
      5. Click Save, right-click Lead Manual Rule, and then click Activate.
    • Follow these steps for a Create rule:
      1. In the Create a Workflow Rule dialog box, type Lead Create Rule in the Rule name box.
      2. In the Select the event box, accept the default value of Create, and then click Next.
      3. In the Select Behavior dialog box, click Insert Action, and then click Run subprocess.
      4. Click Lead Manual Rule in the Subprocess box, and then click OK.
      5. Click Save, right-click Lead Create Rule, and then click Activate.

Import records

Note To follow these steps, you must have an import file that contains lead records.
  1. Start the Microsoft CRM Web client, click Tools, point to Import, and then click Leads.

    The Import Wizard starts.
  2. Click Next, click Browse to select the appropriate import file, and then click Next.
  3. Map any required fields from the import file to the appropriate fields in Microsoft CRM, and then click Next.
  4. Click Import.
  5. Click Start, point to Programs, point to Microsoft CRM, and then click Workflow Monitor.
  6. Type the name of the Microsoft CRM server in the Target Microsoft CRM Server box, and then click OK.
  7. Click the Log tab, and then select Running in the View box.
For more information about the terminology that is used to describe Microsoft product updates, see the following article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbMBSworkflow kbprb kbMBSMigrate kbQFE kbHotfixServer KB893625