Non-delivery report messages from Quarterdeck Mail are not delivered to the mailbox of the sender on an Exchange Server 2003 server (893615)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

Non-delivery report (NDR) messages from Quarterdeck Mail (Qmail) are not delivered to the mailbox of the sender on a Microsoft Exchange Server 2003 server. These NDR messages are put in the local delivery queue on the Exchange server. Additionally, a Warning event that is similar to the following is logged in the Application log: Source: MSExchangeTransport
Category: Exchange Store Driver
Type: Warning
Event ID: 327
Description: The following call : EcSetFileHandleProp to the store failed.
Error code : Error Code. MDB : MDB ID. FID : . MID : . File : Drive:\Path\Queue\filename.EML

CAUSE

This problem occurs when the NDR messages contain Japanese Industry Standards (JIS) characters or other double-byte character set (DBCS) characters.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Exchange Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Jun-2005  03:00  6.5.7233.28     3,261,952  Mdbmsg.dll       
   04-Jun-2005  01:56                      3,304  Redir.asp
   21-Jun-2005  03:33  6.5.7233.28     5,176,832  Store.exe  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbQFE KBHotfixServer kbexchCOEXISTMIGRATION kbfix kbBug kbpubtypekc KB893615 kbAudITPRO