You cannot connect your IrDA compatible mobile telephone to a Windows XP Service Pack 2-based computer (893476)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

If you connect an InfraRed Data Association (IrDA) compatible mobile telephone to the Microsoft Windows XP-based computer, you receive the following message: Found new hardware
You must be a member of the Administrators group on this computer to install this hardware: Classic Mobile Phone If you follow these steps, the Found New Hardware Wizard starts and you are prompted to install the Classic Mobile Phone driver:
  1. You log on to the Windows XP-based computer by using an administrator account.
  2. You connect to an IrDA compatible mobile telephone to the Windows XP-based computer.
These symptoms occur if the following conditions is true:
  • You install Windows XP Service Pack 2 (SP2).
  • The user account with which you logged on does not have administrator permissions.

CAUSE

This problem occurs if either of the following conditions are true:
  • The Classic Mobile Phone driver could not be installed.
  • The IrDA compatible mobile telephone is not compatible with the Classic Mobile Phone driver.
All IrDA compatible mobile telephone that do not have a driver that is provided by Windows XP SP2 use the Classic Mobile Phone driver. The Classic Mobile Phone driver must be installed interactively in Windows XP SP2. To install the Classic Mobile Phone driver, your user account have administrator permissions.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Size     File name
   -----------------------------------------
   05-Feb-2005  01:00  160,176  Mdmirmdm.inf
Important Some IrDA compatible mobile telephones may not be compatible with the Classic Mobile Phone driver. After you install this hotfix, Classic Mobile Phone driver compatible mobile telephones silently install the Classic Mobile Phone driver. If the problem is not resolved after you install this hotfix, download the most current mobile telephone driver from the phone manufacturer Web site.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbDriver kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB893476 kbAudITPRO kbAudEndUser