A printed document contains additional characters or words when you print a Web page that uses Adobe Type 1 fonts in Internet Explorer 6 (893310)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Professional
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you print a Web page that uses Adobe Type 1 fonts, the printed document is incorrect. You may experience the following symptoms:
  • Characters from the beginning or the end of a line in the document are repeated on the next line in the printed document.
  • Words from the beginning or end of a line in the document are repeated on the next line in the printed document.
For example, you print the following text from a Web page:

Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.
Quick brown fox jumped over the lazy dog's back.

In this situation, the printed text may appear similar to the following text:

Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.
back .Quick brown fox jumped over the lazy dog's back.

CAUSE

This problem occurs if you use Microsoft Internet Explorer 6. This is because there is an incompatibility with Adobe font rendering in the Internet Explorer 6 printing engine.

During the page layout process, Internet Explorer measures character widths by using the screen font. However, the MSHTML component in Internet Explorer forces the use of TrueType fonts. This is because certain Adobe fonts are not True Type fonts and because the display code path in Internet Explorer verifies the destination media. Therefore, a different set of widths exists for the characters that are printed.

RESOLUTION

Microsoft Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.Restart requirementYou do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix. Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions
   Date         Time   Version       Size         File name
   ----------------------------------------------------------
   07-Apr-2005  21:32  6.0.3790.305  2,930,688    Mshtml.dll


Windows Server 2003, 64-bit versions
   Date         Time     Version       Size        File name
   ------------------------------------------------------------
   07-Apr-2005  19:30    6.0.3790.305  8,231,424   Mshtml.dll
   07-Apr-2005  19:32    6.0.3790.305  2,930,688   Wmshtml.dll
Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1

In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

Microsoft Windows XP Service Pack 1 (SP1) and Windows XP Service Pack 2 (SP2)

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.Restart requirementYou do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix. Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Service Pack 1
   Date         Time   Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35  6.0.2800.1502  2,703,360   Mshtml.dll


Windows XP Service Pack 2
   Date         Time   Version        Size        File name
   -----------------------------------------------------------
   25-Mar-2005  06:04  6.0.2900.2640  3,011,584   Mshtml.dll
Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1

In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

Microsoft Windows 2000

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesYou must have Internet Explorer 6 Service Pack 1 (SP1) installed to install this hotfix.Restart requirementYou do not have to restart the computer after you apply this hotfix.

Note If the Mshtml.dll file is being used when you apply this hotfix, you must restart the computer after you apply this hotfix. Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size        File name
   ------------------------------------------------------------
   24-Mar-2005  17:35   6.0.2800.1502  2,703,360   Mshtml.dll
Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must set the following registry value to apply the changes that are included in this hotfix:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Printing

Value name: DO_NOT_FORCE_TRUETYPE_K893310
Value type: REG_DWORD
Value data: 0x1

In this registry value, a value of 0x1 enables compatibility support for Adobe fonts when you use them in Internet Explorer. To disable compatibility support for Adobe fonts in Internet Explorer, set this value to 0x0.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbBug kbfix kbQFE kbWinServ2003preSP1fix kbMBSMigrate kbHotfixServer KB893310 kbAudEndUser kbAudITPRO