FIX: Error message when you use the Managed Provider for DB2 to call a stored procedure in Host Integration Server 2004: "Internal Network Library error" (893094)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

When you use the Microsoft Host Integration Server 2004 Managed Provider for DB2 to call a stored procedure, you may receive an "Internal Network Library" error message. This problem occurs when the stored procedure uses InputOutput parameters.

CAUSE

This problem occurs because the Managed Provider for DB2 incorrectly returns an error message when the provider uses commit processing.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Db2oledb.dll6.0.1942.0 487,424 01-Mar-2005 19:54
Db2oledb.hNot Applicable24,516 01-Mar-200519:59
Ddmstr.dll 6.0.1942.044,032 01-Mar-200519:55
Microsoft.hostintegration.msdb2client.dll6.0.1942.0114,688 01-Mar-200520:46
Mseidb2c.dll 6.0.1942.071,680 01-Mar-200519:54
Mseidb2d.dll 6.0.1942.0435,200 01-Mar-200519:55
Mseidrda.dll 6.0.1942.0684,544 01-Mar-200519:55
Note Because of file dependencies, the most recent fix that contains these files may contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbDB2OLEDB kbHIS2004 kbfix kbbug kbQFE kbhotfixserver kbpubtypekc KB893094 kbAudDeveloper