The Rtcspl.exe process unexpectedly quits approximately one time every 28 days, and event IDs 13, 16426, and 16427 are logged in Live Communications Server 2003 (893067)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003

SYMPTOMS

On a computer that is running Microsoft Office Live Communications Server 2003, you may experience all the following symptoms:
  • The Rtcspl.exe process unexpectedly quits approximately one time every 28 days.
  • After the Rtcspl.exe process quits, it automatically restarts.
  • After the Rtcspl.exe process has quit and has been restarted 10 times, the Rtcsrv.exe process unexpectedly quits.
  • All the following events are logged in the Application log:

    Event ID: 13
    Event Type: Error
    Event Source: Live Communications Script-Only Applications Service
    Event Category: (1012)
    Event ID: 13
    Date: date
    Time: time
    User: N/A
    Computer: computername
    Description: Live Communications Script-Only Applications Service aborting because Live Communications Server service terminated unexpectedly.

    Event ID: 16426
    Event Type: Warning
    Event Source: Live Communications Server
    Event Category: (1000)
    Event ID: 16426
    Date: date
    Time: time
    User: N/A
    Computer: computername
    Description: Unable to start a process for 'C:\Program Files\Microsoft LC\Server\RTCSPL.EXE', error code is:0x80070102 (The wait operation timed out. ).

    Event ID: 16427
    Event Type: Warning
    Event Source: Live Communications Server
    Event Category: (1000)
    Event ID: 16427
    Date: date
    Time: time
    User: N/A
    Computer: computername
    Description: The 'C:\Program Files\Microsoft LC\Server\RTCSPL.EXE' process exited prematurely, exit code is:0x1 (Incorrect function. ). The process will be restarted.

CAUSE

This problem occurs because of a problem in the Rtcspl.exe process.

The Rtcspl.exe process is a managed application that calls the WaitHandle.WaitAny method of the Microsoft .NET Framework. The WaitHandle.WaitAny method uses an infinite timeout value. However, this method incorrectly passes a timeout value of 0x7FFFFFFF to the NTDLL function NTWaitForMultipleObjects. The value 0x7FFFFFFF corresponds to about 28 days. The correct value for an infinite timeout is -1.

Because the WaitHandle.WaitAny method passes a value of 0x7FFFFFFF to NTWaitForMultipleObjects, the WaitAny method incorrectly returns a value of 0 (zero). The Rtcspl.exe process interprets this returned zero value to mean that the Rtcsrv.exe process is quitting. Therefore, the Rtcspl.exe process also quits.

When this behavior occurs, the Rtcsrv.exe process is still running. When the Rtcsrv.exe process detects that the Rtcspl.exe process has quit, the Rtcsrv.exe process restarts the Rtcspl.exe process. After the Rtcsrv.exe process has restarted the Rtcspl.exe process 10 times, the Rtcsrv.exe process determines that a problem exists in the Rtcspl.exe process. Therefore, the Rtcsrv.exe process quits.

RESOLUTION

Hotfix information

To download and install this update, visit the following Microsoft Web site:

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart the computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time    Version         Size      File Name 
--------------------------------------------------------------
04-01-2005   11:54   1.0.4949.1079   142,040   Serveragent.dll
04-01-2005   11:54   1.0.4949.1079    19,672   Rtcspl.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbEventLog kbBug kbfix KB893067 kbAudITPRO