A custom transform (MST) file does not copy additional files to user profile folders that were redirected to the network in Office 2003 (892996)



The information in this article applies to:

  • Microsoft Office Professional Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Outlook 2003

SYMPTOMS

When you use a custom transform (MST) file to install Microsoft Office 2003 on a domain client computer, you may experience the following symptoms after the MST file copies additional files to the user profile folders.

These symptoms occur after the user profile folders are redirected to the network.
  • The installation of Office 2003 or the first start of any Office 2003 program causes a rollback. Additionally, the custom action that verifies the user settings is not completed.
  • No files are copied to the user profile folders that were redirected to the network.
Note Examples of the user profile folders include the Application Data folder, the Desktop folder, or the My Documents folder.

MORE INFORMATION

The name of the custom action that is not completed successfully starts with "OCW_Verify_." The following sample displays a verbose installation log file that shows the OCW_Verify_ action:

MSI (s) (50:20) [10:33:26:758]: Executing op: SetSourceFolder(Folder=c:\DOCUME~1\User1\LOCALS~1\Temp\)
MSI (s) (50:20) [10:33:26:758]: Executing op: SetTargetFolder(Folder=\\Server\User1\Application Data\Microsoft\Templates\)
MSI (s) (50:20) [10:33:26:773]: Executing op: FileCopy(SourceName=~OCW0014.TMP,,DestName=Normal.dot,Attributes=32,FileSize=31232,PerTick=32768,IsCompressed=0,VerifyMedia=0,,,,,,,,InstallMode=262144,,,,,,,)
MSI (s) (50:20) [10:33:26:773]: File: \\Server\User1\Application Data\Microsoft\Templates\Normal.dot;	To be installed;	Won't patch;	No existing file
MSI (s) (50:20) [10:33:26:773]: Source for file '~OCW0014.TMP' is uncompressed, at 'c:\DOCUME~1\User1\LOCALS~1\Temp\'.
MSI (s) (50:20) [10:33:26:789]: Note: 1: 2318 2: \\Server\User1\Application Data\Microsoft\Templates\Normal.dot 
MSI (s) (50:20) [10:33:29:679]: Executing op: CustomActionSchedule(Action=OCW_Verify_User_Settings_Files,ActionType=3073,Source=BinaryData,Target=_OCW_Verify_User_Settings_Files@4,CustomActionData=\\Server\User1\Application Data\Microsoft\Office\Templates\Normal.dot*3822A6E949E0A21D52533853EDB9EF8B
MSI (s) (50:74) [10:33:29:695]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI1DC.tmp, Entrypoint: _OCW_Verify_User_Settings_Files@4
Action ended 10:33:29: InstallExecute. Return value 3.

Text entries in the sample demonstrate how the files are copied to the user profile folders that were redirected to the network. The text entries show a Normal.dot template file that was copied to a user profile folder that was redirected to the network.

CAUSE

This problem occurs because the OCW_Verify_ custom action uses local computer account credentials instead of the domain user credentials to access the user profile folders that were redirected to the network.

WORKAROUND

To work around this problem, use one of the following methods:

Method 1: Do not redirect user profile folders

Do not redirect user profile folders such as the Application Data folder or the My Documents folder.

Method 2: Use a logon script to copy files to the user profile folders that were redirected to the network

You can create a logon script on the domain server. The logon script runs automatically when a user logs on to the domain. The script copies all the required files to the user profile folders. When you use a logon script, you must not use the MST file to copy any additional files to the user profile folders that were redirected to the network.

Method 3: Add a batch file to the MST file to copy files

You can add a batch file to the MST file to copy all the required files to user profile folders that were redirected to the network. To add the batch file to the MST file, follow these steps:
  1. Start the Custom Installation Wizard program.
  2. On the Add Installation and Run Programs page, click Add.
  3. In the Add Program Entry dialog box, click Browse to specify the location of the batch file.
  4. If you want to specify any command-line options for the executable batch file, type the command-line options in the Arguments dialog box.
  5. In the Add Program Entry dialog box, click to select the Run this program once for each user check box.
  6. In the Add Program Entry dialog box, click to select the Run this program for the first time this product is installed check box.
  7. Click OK.

Method 4: Change permissions on the redirected folder

Change permissions on the redirected folder so that the computer account has read access to the redirected folder.

Note This method only works in a Windows 2000 or Windows 2003 domain.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how to download the latest Office 2003 Resource Kit, visit the following Microsoft Web site:http://www.microsoft.com/downloads/details.aspx?FamilyID=4bb7cb10-a6e5-4334-8925-3bcf308cfbaf&DisplayLang=en
For additional information about how to troubleshoot Office 2003 Setup problems, click the following article number to view the article in the Microsoft Knowledge Base:

826511 How to use a setup log file to troubleshoot setup problems in Office 2003

For additional information about Office 2003 Resource Kit related issues, click the following article number to view the article in the Microsoft Knowledge Base:

835209 Office 2003 Resource Kit hotfix package: February 10, 2004


Modification Type:MinorLast Reviewed:9/27/2006
Keywords:kbtshoot KB892996 kbAudITPRO