Live Communications users cannot communicate with other users in Live Communications Server 2005 Enterprise Edition (892990)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition

SYMPTOMS

After you configure an Enterprise pool in Microsoft Office Live Communications Server 2005 Enterprise Edition, you experience the following symptoms:
  • Users whose computers are enabled for Live Communications can connect to a Live Communications Server 2005 Enterprise Edition server by using the fully qualified domain name (FQDN) of that server. These users can see other users' presence information. However, when a user tries to send an instant message to another Live Communications user, or when a user tries to initiate an audio session or a video session with another Live Communications user, the user who tries to initiate communications receives the following error message:
    The message could not be sent to all users.
  • If you perform client-side logging in Live Communications Server 2005, you notice the following output in the client trace log files:

    18:00:16.824 DFC:8C0 ERROR :: gethostbyname failed for host pool.example.contoso.com, error: 0x2afc18:00:16.824 DFC:110 ERROR :: 
    OUTGOING_TRANSACTION::OnRequestSocketConnectComplete - connection failed error 80ee0066

CAUSE

This issue occurs if the following conditions are true:
  • The Live Communications Server pool does not have the FQDN of that pool published in Domain Name System (DNS).
  • The client program, such as Windows Messenger, is configured to connect to the FQDN of the Live Communications Server computer instead of connecting to the FQDN of the pool that is published in DNS.
Live Communications Server 2005 Enterprise Edition requires that the FQDN of the pool be published in DNS so that client programs and front-end servers can resolve this pool name.

When a Live Communications user (User A) invites another user (User B) to an instant messaging session, to an audio session, or to a video session, User A must send a sequence of session initiation messages to User B. These session initiation messages travel through the Live Communications Server Enterprise Edition server in the pool. The last message in this handshake sequence is known as the ACK request. This ACK request is addressed to the FQDN of the pool. Therefore, the client program tries to resolve the FQDN of the pool to an IP address. If the pool name is not registered in DNS, this name resolution is not successful.

RESOLUTION

To resolve this issue, configure a host record in DNS for the FQDN of the Live Communications Server pool. Additionally, configure the client program to connect to this pool name.

Note A host record is also known as an "A record."

Note In Live Communications Server 2005 Enterprise Edition, we recommend that you configure the client program to connect to the FQDN of the pool, even if you have only one Live Communications Server Enterprise Edition server in your pool.

MORE INFORMATION

For additional information about how to deploy and to configure Live Communications Server 2005, see the Live Communications Server 2005 deployment resources. To obtain these deployment resources, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:2/17/2005
Keywords:kbtshoot kbprb KB892990 kbAudITPRO