The Web Service performance object does not appear in the Performance object list or it may appear as a number instead of the name "Web Service" in Windows 2000 (892929)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

If you use the System Monitor tool, the Web Service performance object may not appear in the Performance object list, or it may appear as a number instead of the name Web Service. This symptom occurs if you use the System Monitor tool on your Microsoft Windows 2000-based computer. When this symptom occurs, programs that use the Web Service performance object may not work correctly.

Note The Web Service performance object is not available in the System Monitor tool if the World Wide Web Publishing service is stopped.

CAUSE

This problem occurs if two or more performance objects request data from the Web Service performance object at the same time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   24-Jan-2005  08:36  5.0.2195.6982  337,168  Asp.dll          
   19-Jun-2003  20:05  5.0.2195.6620  299,792  Fscfg.dll        
   19-Jun-2003  20:05  5.0.2195.6620    8,464  Ftpctrs2.dll     
   19-Jun-2003  20:05  5.0.2195.6620    6,416  Ftpmib.dll       
   19-Jun-2003  20:05  5.0.2195.6620    9,488  Httpmib.dll      
   19-Jun-2003  20:05  5.0.2195.6666   13,584  Infoadmn.dll     
   24-Jan-2005  08:36  5.0.2195.7023  248,080  Infocomm.dll     
   19-Jun-2003  20:05  5.0.2195.6709   62,736  Isatq.dll        
   19-Jun-2003  20:05  5.0.2195.6620    7,440  W3ctrs.dll       
   24-Jan-2005  08:36  5.0.2195.6982  349,968  W3svc.dll        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB892929 kbAudITPRO kbAudDeveloper