You receive different HTTP status codes when you post a document to a one-way HTTP receive port in BizTalk Server 2004 (892921)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Service Pack 1


SYMPTOMS

When you post a document to a one-way HTTP receive port in Microsoft BizTalk Server 2004, you may receive one of the following HTTP status codes:
  • If an element is not valid, the client receives an HTTP 500 status code.
  • If an attribute is not valid, you receive an HTTP 202 status code, and the message is suspended.
You should receive the same HTTP status code, and the message should not be suspended. The status code should not depend on why the document failed validation.

CAUSE

This problem occurs because not all the failure paths are covered in the BizTalk Server HTTP Adapter. This problem occurs in the BizTalk Server HTTP Adapter and is corrected in this hotfix.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have BizTalk Server 2004 Service Pack 1 (SP1) installed before you install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date            Version            Size    File name
   --------------------------------------------------------------
  8-Feb-2005       3.00.6100.00       144,896 Btshttpreceive.dll  


Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBizTalk2004preSP1fix kbbug kbfix kbHotfixServer kbQFE KB892921 kbAudITPRO