You receive an "Access is denied" error message when you install the Bluetooth stack and detect a Bluetooth device in Microsoft Windows XP Service Pack 2 (892891)



The information in this article applies to:

  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP2

Notice

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you install the Microsoft Bluetooth stack and detect a Bluetooth device in Microsoft Windows XP Service Pack 2 (SP2), you receive an "Access is denied" error message. Additionally, your computer cannot configure the Bluetooth device.

CAUSE

This problem may occur if you connect a Bluetooth device to a computer that has the Atheros wireless local area network (LAN) adaptor installed. The first time that you start your computer after you upgrade to Windows XP SP2, or the first time that you start a computer that has Windows XP SP2 installed, the Windows security database may become corrupted. If you install the Bluetooth stack when the Windows security database is corrupted, the wrong user right is set to the registry key that is required to configure the Bluetooth device. Therefore, the Bluetooth device does not configure correctly.

WORKAROUND

To verify whether the Windows security database is corrupted, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type

    esentutl /g %windir%\security\database\secedit.sdb



    You should receive output that is similar to the following output:

    Microsoft(R) Windows(TM) Database Utilities
    Version 5.1
    Copyright (C) Microsoft Corporation. All Rights Reserved.
    
    Initiating INTEGRITY mode...
            Database: C:\WINDOWS\security\database\secedit.sdb
      Temp. Database: TEMPINTEG1704.EDB
    
    Checking database integrity.
    
                         Scanning Status (% complete)
    
              0    10   20   30   40   50   60   70   80   90  100
              |----|----|----|----|----|----|----|----|----|----|
              ...................................................
    
    
    Integrity check successful.
    
    Operation completed successfully in 1.592 seconds.
    

    If the Windows security database is corrupted, the output will contain the following line:

    This operation may find that this database is corrupt.

To work around this problem, follow these steps:
  1. If both the Edb.log file and the Edb.chk file are in the %windir%\security directory, follow these steps to repair the security database:
    1. Click Start, click Run, type cmd, and then click OK.
    2. At the command prompt, type

      esentutl /r edb /l %windir%\security /s %windir%\security

  2. If either the Edb.log file or the Edb.chk file is in the C:\WINDOWS\security directory, or if neither file exists in the directory, follow these steps to repair the security database:
    1. Click Start, click Run, type cmd, and then click OK.
    2. At the command prompt, type

      esentutl /p %windir%\security\Database\secedit.sdb

    3. Click OK when you receive the following message:You should only run Repair on damaged or corrupted databases. Repair will not apply information in the transaction log files on the database, and may cause information to be lost. Do you wish to proceed?
  3. After you repair the security database, follow these steps to modify the registry so that you can access the registry key that is required to configure the Bluetooth device:
    1. Create the C:\bt.inf file that has the following text.
        [version]
        signature="$CHICAGO$"
        revision=1
        DriverVer=07/01/2001,5.1.2600.1106
      
        [Registry Keys]
        "MACHINE\SYSTEM\CurrentControlSet\Services\BTHPORT",0,"D:AR(A;CI;GRGW;;;PU)(A;CI;GRGW;;;LS)"
      
    2. Click Start, click Run, type cmd, and then click OK.
    3. At the command prompt, type

      secedit /configure /cfg C:\bt.inf /db C:\bt.sdb

    4. Delete the C:\bt.inf file and the C:\bt.sdb file.
Note Before you follow the steps that are outlined in this article, verify that the Bluetooth Support service has been started and that the Bluetooth Support service is configured to use the local administrator account. For more information about how to troubleshoot the Bluetooth Support service, click the following article number to view the article in the Microsoft Knowledge Base:

894035 The Bluetooth Devices item is not present when you open Control Panel

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

884018 You cannot add a Windows component in Windows XP


Modification Type:MinorLast Reviewed:5/3/2006
Keywords:kbregistration kberrmsg kbprb KB892891 kbAudITPRO