When you use an asterisk to indicate a wildcard character, no records are returned in Microsoft CRM 1.2 Sales for Outlook (892548)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

You perform a search in Microsoft Business Solutions CRM 1.2 Sales for Outlook (the Outlook client). When you use an asterisk (*) to indicate a wildcard character, no records are returned. If you use a percent sign (%) to indicate a wildcard character when you perform the same search, records are returned.

CAUSE

The Outlook client uses the percent sign as the wildcard character for searches. It does not use the asterisk as the wildcard character.

Note The Microsoft CRM Web application uses the asterisk as the wildcard character in searches.

WORKAROUND

If you are using the Outlook client, use a percent sign to indicate a wildcard character in searches.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to reproduce the behavior

This example assumes that the following conditions are true:
  • You are using a computer that has Microsoft CRM 1.2 and the Adventure Works sample data installed.
  • There is at least one computer in the organization that has the Outlook client installed.
  1. In the Outlook client, click CRM Appointment on the toolbar.
  2. Enter data in all the required fields.
  3. Click Regarding to select the record for this appointment.
  4. In the Find box, type *Bike*, and then click Go.

    No records are returned.
  5. In the Find box, type %Bike%, and then click Go.

    Records are returned.

REFERENCES


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbMBSMigrate kbBug KB892548 kbAudEndUser