The Microsoft Exchange Information Store service may stop responding when you try to back up your Exchange 2003 database files by using a program that uses the Volume Shadow Copy Service (892514)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

When you try to back up your Microsoft Exchange Server 2003 database files, the Microsoft Exchange Information Store service may stop responding. This problem occurs when the following conditions are true:
  • The computer is running Microsoft Exchange Server 2003 Service Pack 1 (SP1).
  • The program that you use to back up the database uses the Volume Shadow Copy Service in Microsoft Windows Server 2003.
  • You dismount the database after the Volume Shadow Copy Service backup is finished.

CAUSE

This problem occurs because of a deadlock condition that may occur when you dismount the Exchange database after the Volume Shadow Copy Service backup operation is finished.

This deadlock condition occurs if all the following conditions are true:
  • The freeze period of the Volume Shadow Copy Service backup operation starts.
  • During this freeze period, Exchange receives a commit operation, or Exchange receives another operation that performs logging and that then waits for the log files to be flushed.
  • You dismount the Exchange database after the Volume Shadow Copy Service backup operation is finished.
Under these conditions, the operation that Exchange receives enters the buffer in Exchange. However, the signal to flush the log file does not run because of the Volume Shadow Copy Service freeze. When the freeze is finished, the thread that performs the thaw operation does not try to flush the log. Therefore, the operation that Exchange receives waits indefinitely. Because of this, the Microsoft Exchange Information Store service stops responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, your computer must be running Exchange Server 2003 SP1 to install this hotfix. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

If you are running a program that locks one or more .dll files when you apply this hotfix, you might have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
01-Feb-2005  21:17  6.5.7232.76     2,114,560  Ese.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbExchange2003preSP2fix kbfix kbBug kbExchange2003preSP1fix KB892514 kbAudITPRO