You receive an error message when you try to save a default Microsoft CRM role in a child business unit (892497)



The information in this article applies to:

  • Microsoft CRM 1.2

SYMPTOMS

You may receive an error message in Microsoft Business Solutions CRM (Microsoft CRM) when you try to save a default Microsoft CRM role in a child business unit.
  • If the DevErrors parameter is set to Off in the Web.config file of the Microsoft CRM Web site directory, you receive the following error message:
    An Unknown error has occurred. Please contact your system administrator.
  • If the DevErrors parameter is set to On in the Web.config file of the Microsoft CRM Web site directory, you receive the following error message:
    Error Description: An object with the specified name already exists in the Active Directory.
If you change the privilege of the default Microsoft CRM role, the privilege reverts to the original access level when you open the role again.

CAUSE

This problem occurs when you try to modify a Microsoft CRM role in a business unit that has two child business units.

WORKAROUND

To change a privilege to a Parent:Child business unit access level, you must change the privilege in the Microsoft CRM role at the root business unit level.

To work around this problem, use the example in the More Information section, and then grant Create Account Record privileges for the Sales and Marketing unit. To do this, follow these steps:
  1. Log on to Microsoft CRM as a Microsoft CRM system administrator.
  2. Click GoTo, point to Home, and then click Settings.
  3. On the Settings page, click Business Unit Settings.
  4. On the Business Unit Settings page, click Security Roles.
  5. In the Business Unit list, click Adventure Works Cycle.
  6. To open the default Salesperson role, double-click Salesperson.
  7. To change the access level to Organization, click Create on the Core Records tab.
  8. On the File menu, click Save and Close.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem can occur, for example, when you work with the Adventure Works Cycle sample company in Microsoft CRM and use the following structure for the business unit:

Root business unit: Adventure Works Cycle
Child of the root business unit: Sales and Marketing
Child of Sales and Marketing: Field Sales
Child of Field Sales: Central Region

Steps to reproduce the problem

To reproduce the problem, follow these steps:
  1. Log on to Microsoft CRM as a Microsoft CRM system administrator.
  2. Click GoTo, point to Home, and then click Settings.
  3. On the Settings page, click Business Unit Settings.
  4. On the Business Unit Settings page, click Security Roles.
  5. In the Business Unit list, click Sales and Marketing.
  6. To open the default Salesperson role, double-click Salesperson.
  7. To change the access level to Parent:Child Business Units, click Create under Account Record Type on the Core Records tab.
  8. On the File menu, click Save and Close.
If you do not receive one of the error messages that is listed in the Symptoms section, double-click Salesperson to open the default Salesperson role. Note that the privileges revert to the original access level on the Core Records tab.

REFERENCES

For additional information about the DevErrors parameter of the Web.config file, click the following article number to view the article in the Microsoft Knowledge Base:

857192 How to use the web.config file to show more detailed error messages in Microsoft Business Solutions CRM (Microsoft CRM)


Modification Type:MinorLast Reviewed:8/11/2005
Keywords:kbMBSadministration kbMBSMigrate kbBug KB892497 kbAudEndUser kbAudITPRO