The secondary child site may not receive all the offer files in a Systems Management Server 2.0 hierarchy (892478)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

In a Microsoft Systems Management Server 2.0 hierarchy, when you create two or more advertisements on a primary site at the same time, the secondary child site may not receive all the offer files (.ofr files).

Additionally, an error message that is similar to the following may appear on the SMS 2.0 client computers:
SMS error message id 10000 A data integrity error was detected for advertisement "S00202E7" (\\smsserver\CAP_S01\OfferInf.box\S00202E7.ofr). The operating system reported error 2: The system cannot find the file specified.
This problem occurs when the SMS 2.0 Offer Manager component receives two or more incoming offer files on a secondary child site at the same time.

CAUSE

This problem occurs because the client access point is not updated correctly.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have SMS 2.0 Service Pack 5 (SP5) installed before you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, this hotfix will restart the SMS service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   ---------------------------------------------------------
   09-Feb-2005  10:57                  12,998  Filemap.ini
   20-Feb-2004  02:03  2.0.6.7        355,242  Smsupdate.exe
   05-Aug-2000  17:51  2000.80.194.0  274,489  Ntwdblib.dll
   25-Feb-2003  10:20  2.0.1493.5200   72,544  Offermgr.dll
   22-Feb-2003  18:05  2.0.1493.5011  855,312  Preinst.exe

Hotfix deployment instructions

To deploy this hotfix, follow these steps:
  1. Create a shared folder in a location that SMS site servers can access.
  2. Copy the SMS2.0-SP5-KB892478-X86-ENU.exe hotfix file to the new shared folder.
  3. On each SMS primary and secondary site server in your environment, log on by using an account that has administrative credentials.
  4. If the SMS Administrator console is open, close the console.
  5. On each primary and secondary site server, connect to the shared folder that contains the hotfix, double-click the SMS2.0-SP5-KB892478-X86-ENU.exe hotfix file, and then follow the instructions in the wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbQFE kbHotfixServer kberrmsg kbsms200preSP4fix kbfix kbbug kbpubtypekc KB892478 kbAudITPRO