You receive an error message when you view a page that contains a graphic in Publisher 2002 (892418)



The information in this article applies to:

  • Microsoft Publisher 2002

SYMPTOMS

When you view a page that contains a graphic in Microsoft Publisher 2002, you receive the following error message:
Microsoft Publisher has encountered a problem and needs to close. We are sorry for the inconvenience.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature that is similar to the following error signature:
   Application name   Application version   Module name  Module version   Offset
   -------------------------------------------------------------------------------
   Mspub.exe          10.0.2621.0           Ntdll.dll    5.1.2600.1217    00033aed

CAUSE

This issue may occur if one or more of the following conditions are true:
  • You have a damaged printer driver.
  • The page contains a damaged graphic.
  • The page contains a graphic that was scanned at a high resolution.

WORKAROUND

To work around this issue, use one of the following methods.

Method 1: Test for a damaged printer driver

To determine whether your current printer driver is damaged, follow these steps to test your publication by using a different printer driver:
  1. Close Publisher and change your default printer in Control Panel.

    Note If you do not have another printer driver installed, install either the Microsoft Publisher Color Printer or the Microsoft Publisher Imagesetter printer driver. Then, set the printer as the default printer.

    For more information about how to install the Microsoft Publisher Color Printer or the Microsoft Publisher Imagesetter printer driver, see the "More Information" section.
  2. Start Publisher 2002, and then open the file that the error occurred in.

    If you can successfully open your publication without errors after you change your current printer driver, you have a damaged printer driver installed on your computer. To correct this problem, reinstall the printer driver.

    For information about how to contact your printer manufacturer for help when you reinstall your damaged printer driver, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

    65416 Hardware and software vendor contact information, A-K

    60781 Hardware and software vendor contact information, L-P

    60782 Hardware and software vendor contact information, Q-Z

Method 2: Paste the graphic as an Enhanced Metafile

  1. Right-click the graphic, and then click Cut.
  2. On the Edit menu, click Paste Special.
  3. In the Paste Special dialog box, click Picture (Enhanced Metafile), and then click OK.

Method 3: Save the graphic file in a graphics editor program

  1. Import the graphic in a graphics editor program, such as Adobe Illustrator.
  2. Change the resolution of the graphic to your optimum resolution for your printer. For example, a 300 DPI image would be optimized for printing at 1250 DPI or a higher resolution. For additional information about other graphic resolution suggestions, click the following article number to view the article in the Microsoft Knowledge Base:

    292276 General information about scanning resolution in Publisher

  3. Save a copy of the graphic to a new file with a new file name.
  4. Insert the new graphic file in your Publisher 2002 publication.
For additional information about a possible resolution if the graphic is a TIFF file, click the following article number to view the article in the Microsoft Knowledge Base:

818636 Office XP program stops responding when you insert a TIFF file in a document or in an e-mail message

MORE INFORMATION

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

To install the Microsoft Publisher Color Printer or the Microsoft Publisher Imagesetter printer driver, follow these steps:
  1. Click Start, and then click Printers and Faxes.
  2. Click Add a printer. The Add Printer Wizard starts. Click Next.
  3. Click Local printer attached to this computer, click to clear the Automatically detect and install Plug and Play printer check box, and then click Next.
  4. Click Use the following port, click FILE: (Print to File) in the list box, and then click Next.
  5. In the Manufacturer list, click Generic.
  6. In the Printers list, click one of the following, and then click Next:
    • If you know that your printing service will use an imagesetter, click MS Publisher Imagesetter.
    • If you are not sure how your files will be prepared, click MS Publisher Color Printer.
  7. If you previously installed a Microsoft Publisher driver, you may be prompted to either keep the existing driver or install a new one. We recommend that you click Keep existing driver, and then click Next.
  8. In the Name Your Printer pane, specify the printer name that you want. We recommend that you keep the default name.
  9. If you have other printers installed on your computer, click No under Do you want to use this printer as the default printer?, and then click Next.
  10. Click Do not share this printer, and then click Next.
  11. Click No under Do you want to print a test page?, and then click Next.
  12. Click Finish to close the Add Printer Wizard.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:1/26/2005
Keywords:kberrmsg kbprinters kbopenfile kbtshoot kbprb KB892418 kbAudEndUser