After you restore Live Communications Server 2005 from a backup, users cannot connect to Live Communications Server, and event ID 30961 is logged in the Application log (892372)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Standard Edition

SYMPTOMS

Consider the following scenario. You follow the steps in the Live Communications Server 2005 Standard Edition Deployment Guide to back up Microsoft Office Live Communications Server 2005 Standard Edition. Later, you restore the Live Communications Server information by following the steps in the Live Communications Server 2005 Standard Edition Deployment Guide. After you do this, you experience all the following symptoms:
  • When a user tries to connect to Live Communications Server, he or she receives the following message:Signing in to SIP Communications Service failed because the service is temporarily unavailable. Please try again later.
  • If you try to view the properties of a user account by using the Live Communications Server 2005 Microsoft Management Console (MMC) snap-in, you receive the following error message:
    MMC snap-in failed to read one or more propery from WMI. If this is a new user then it may not have been picked up the User Replicator yet. Please try again a few moments later.
    Note In this error message, the word "property" is misspelled as "propery." Additionally, the word "by" is missing between "picked up" and "the User Replicator."
  • The following event is logged in the Application log on the Live Communications Server 2005 computer:Event Source: Live Communications User Services
    Event Category: (1006)
    Event ID: 30961
    Date: date
    Time: time
    Type: Error
    User: N/A
    Computer: computername
    Description: Failed to connect to backend database. Live Communications Server will continuously attempt to reconnect to the backend. While this condition persists, incoming messages will receive error responses.

    Backend Server: (local)\rtc Database: rtc Connection string of:
    driver={SQL Server};Trusted_Connection=yes;AutoTranslate=no;server=(local)\rtc;database=rtc;network=dbmslpcn;
    Cause: Possible issues with backend database.
    Resolution:
    Ensure the backend is functioning correctly.

    For more information, see Help and Support Center at
    http://support.microsoft.com.

CAUSE

This problem occurs if the Live Communications Server local groups are not mapped to the serveracct database role, the adminacct database role, and the roacct database role. This problem occurs because the reinstallation of Live Communications Server re-creates the Live Communications Server local groups. Therefore, when you restore the Microsoft SQL Server database information after you reinstall Live Communications Server 2005, the database permissions for the Live Communications Server local groups are not restored. Live Communications Server cannot connect to the database because the local groups do not have rights to the serveracct database role, the adminacct database role, and the roacct database role.

RESOLUTION

To resolve this problem, map the Live Communications Server local groups to the serveracct database role, the adminacct database role, and the roacct database role. To do this, follow these steps:
  1. Insert the Live Communications Server CD into the CD drive or the DVD drive.
  2. Click Start, click Run, type cmd, and then click OK.
  3. At the command prompt, type the following command, and then press ENTER:

    cscript drive \setup\i386\DBsetup\dbsetup.wsf /setsecurity /serveracct:"localcomputername\RTC Server Local Group" /adminacct:"localcomputername\RTC Local User Administrators" /roacct:"localcomputername\RTC ABS Service Local Group"

    Note In this command, replace the placeholders as follows:
    • Replace drive with the letter of the drive that contains the Live Communications Server CD.
    • Replace localcomputername with the name of the Live Communications Server computer.
    The following results are returned:

    Connecting to SQL Server on <computername>\rtc
    Successfully added account(s) to the specified database role(s).

    Note The Dbsetup.wsf script is also located in the C:\Program Files\Common Files\Microsoft LC 2005\DBSetup\ folder.
  4. Quit the command prompt.
Note You do not have to restart the Live Communications Server service after you follow these steps.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you restore the Live Communications Server database by using the Dbbackup command, you must manually restart the Live Communications Server service. The Dbbackup restore operation stops the Live Communications Server service, but does not restart the Live Communications Server service.

To obtain Live Communications Server 2005 deployment resources and other guides, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbpending kbBug kbtshoot kbprb KB892372 kbAudITPRO