When you are offline in Microsoft CRM 1.2 Sales for Outlook, you cannot open records that you own or you cannot see records that you own (892352)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

When you use Microsoft Business Solutions CRM 1.2 Sales for Outlook, you experience one of the following symptoms:
  • You cannot open records that you own after you click Go Offline. When you click a Microsoft CRM Sales for Outlook folder, such as the Accounts folder, you receive one of the following error messages:
    "You do not have sufficient permissions or access rights to perform this action."
    "An error has occurred. For more information, contact your system administrator."
    "Could not retrieve the view information from the list"


    Note The error message that you receive depends on the DevErrors settings that are listed in the Web.config file of the Microsoft CRM Web site directory.

    For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

    857192 How to use the Web.config file to show more detailed error messages in Microsoft Business Solutions CRM (Microsoft CRM)

  • You do not see any records that you own after you click Go Offline. Verify this by querying the MSDE_MSCRM database for records that you own. If your Microsoft CRM security role has User level Read privileges for records, such as Account, Contact, or Lead records, you will not see these records in the MSDE_MSCRM database tables.

    Note When you log off from Microsoft CRM Sales for Outlook, you can access only the records that you select to bring offline. These records are stored in an MSDE_MSCRM database on the local computer.
To determine whether any records have been copied to the MSDE_MSCRM database on your local computer, follow these steps before you log off.

Note The following procedure assumes that you have at least User level Read privileges for Account records and that you own at least one Account record in Microsoft CRM.
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following command, and then press ENTER:

    OSQL -S Name_of_Sales_for_Outlook_Computer\CRM -E

    Note Name_of_Sales_for_Outlook_Computer is the name of the computer where Microsoft CRM Sales for Outlook is installed.
  3. Type the following commands. Press ENTER after each command.

    use mscrm_msde

    go

    select count (*) from accountbase

    go


If no records are returned, no Account records that you own in Microsoft CRM were copied to the MSDE_MSCRM database on the local computer when you went offline. You can also follow this procedure with the ContactBase and LeadBase tables.

CAUSE

This problem may occur for the following reasons:
  • The security role that is assigned to your Microsoft CRM user account does not have privileges to view records. For example, Read privileges for Account records may be set to None Selected for your security role. In this case, you cannot see Account records when you work online or offline in Microsoft CRM Sales for Outlook.

    Note This behavior is by design.
  • You do not own any records in Microsoft CRM. You will not see any data when you work offline if you are assigned a security role that has User level access only and if you do not have any records that you own. If your security role has User level access, you cannot see the records of other users, even if those records exist in the same business unit.

    Note This behavior is by design.
  • The security role that is assigned to you in Microsoft CRM is set up with User level Read privileges. Additionally, you work in a Microsoft CRM environment where the Microsoft CRM server is installed in a different domain from the Microsoft CRM Sales for Outlook computer.

    Note If this condition is true and if you experience one of the symptoms that is described in the "Symptoms" section, install the hotfix that is described in the "Resolution" section.
  • The security role that is assigned to you in Microsoft CRM is set up with User level Read privileges. Additionally, the Microsoft CRM Sales for Outlook computer was installed in workgroup mode instead of being joined to a domain.

    Note If this condition is true and if you experience one of the symptoms that is described in the "Symptoms" section, install the hotfix that is described in the "Resolution" section.
  • The security role that is assigned to you in Microsoft CRM is set up with User level Read privileges. Additionally, the Microsoft CRM Sales for Outlook computer accesses the Microsoft CRM server and data through a virtual private network (VPN) connection.

    Note If this condition is true and if you experience one of the symptoms that is described in the "Symptoms" section, install the hotfix that is described in the "Resolution" section.

RESOLUTION

Microsoft Business Solutions CRM has a fix for these problems that is part of a cumulative update. The cumulative update information is described in the following Microsoft Knowledge Base article:

904435 Update Rollup 2 is available for Microsoft CRM 1.2

REFERENCES

See the Microsoft CRM Help file and "Chapter 18: Microsoft CRM Security" in the Microsoft CRM Implementation Guide for more information about Microsoft CRM security roles and privileges.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

833621 Microsoft Business Solutions CRM Sales for Outlook 1.2 enhancements


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kberrmsg kbprb kbMBSMigrate kbQFE kbHotfixServer KB892352