The Exchange Server 2003 Recipient Update Service continually updates some recipients or public folders with random SMTP proxy addresses (892298)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

The Microsoft Exchange Server 2003 Recipient Update Service continually updates some recipients or public folders with what appear to be random SMTP proxy addresses. When this problem occurs, you experience one or more of the following symptoms:
  • The number of SMTP proxy addresses may continue to increase.
  • The performance of Windows domain controllers may decrease.
  • Lsass.exe may use close to 100% of processor resources.

CAUSE

This problem may occur if the Recipient Update Service cannot recognize addresses as valid. Therefore, the Recipient Update Service continues to stamp the addresses with additional random SMTP proxy addresses.

The most common cause is a change to the default recipient policy, such as using %g.%s wildcards instead of %m wildcards. If %g.%s wildcards are used, non-user objects that do not use the given name and surname attributes, such as resource mailboxes and public folders, are evaluated incorrectly when the recipient policy is applied.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version      Size        File name
   --------------------------------------------------------    
   02-Jun-2004   03:48   6.5.7231.0   8,902,656   Mad.exe 

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information about the naming schema for Exchange Server software updates, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbExchange2003preSP1fix KB892298 kbAudITPRO