You cannot connect to a host computer by using a RAS PPP direct cable connection in Windows XP (892235)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

In Microsoft Windows XP Professional or in Microsoft Windows XP Home Edition, you cannot connect to a host computer by using a RAS PPP direct cable connection. This problem may occur if the server that you are trying to connect to requires parity to connect. The connection may fail even if you set parity for the client connection.

However, you may be able to connect by using a RAS PPP direct cable connection if you configure the RAS PPP connection to show the terminal window. To do this, in the RAS PPP connection, in the Properties window, click to select the Show terminal window check box.

CAUSE

This problem occurs because the connection settings in Windows XP are hard coded to prevent users from changing the default settings.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Windows XP Service Pack 2 before you install this hotfix.

Restart requirement

You must restart the computer after you apply the hotfix.

Hotfix replacement information

The hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   ---------------------------------------------------------
   11-Apr-2005  23:25  5.1.2600.2651     236,544  Rasapi32.dll     
   11-Apr-2005  23:25  5.1.2600.2651     658,432  Rasdlg.dll  

WORKAROUND

You can use one of the following methods to work around this problem.
  • Configure the server so that it does not require parity. On Windows XP client computers, in the RAS PPP connection, set Parity to None. To do this, follow these steps:
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Network Connections, right-click Incoming connections, and then click Properties.
    3. Click the General tab, click the appropriate device for the incoming connection, and then click Properties.
    4. Click the Advanced tab, in the Parity list, click None, and then click OK two times.
  • On Windows XP client computers, in the RAS PPP connection, configure Show terminal window. To do this, follow these steps:
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Network Connections, right-click the appropriate connection, and then click Properties.
    3. Click the General tab, in the Select a device list, click the appropriate device for the connection, and then click Configure.
    4. Select the Show terminal window check box, and then click OK two times.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbbug KB892235 kbAudEndUser kbAudITPRO