Folder redirection does not redirect folders on Windows XP Professional-based computers (892227)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)

SYMPTOMS

You configure folder redirection for the My Documents folder for all Microsoft Windows XP Professional-based computers. However, folder redirection does not redirect folders from the local profile location, or from an existing remote Universal Naming Convention (UNC) path, to the new location.

When you view the Fdeploy log, you see the following error message:
Unable to expand %HOMESHARE%%HOMEPATH%, error 59. ERROR_UNEXP_NET_ERR winerror.h
# An unexpected network error occurred.
Problem identified to function CUsrInfo::GetHomeDir where NetUserGetInfo returned error 53
ERROR_BAD_NETPATH winerror.h
# The network path was not found.


Note "Error 59" errors can occur because of other issues also. "Error 59" errors are not specific to this issue only.

CAUSE

This problem may occur if the Windows XP Professional-based computer cannot resolve the name of the domain controller when a user logs on to the network.

If the name of the domain controller cannot be resolved, the following scenario occurs:
  • When a user logs on to the network and folder redirection is configured, the computer must resolve the %homeshare%%homepath% environment variables for the user who logs on.
  • If the name of the domain controller cannot be resolved, the computer cannot resolve the %homeshare%%homepath% environment variables for the user.
  • If the %homeshare%%homepath% environment variables cannot be resolved, the following error is returned:
    error 59, ERROR_UNEXP_NET_ERR, An unexpected network error occurred.
Typically, this scenario occurs if Microsoft Windows Internet Name Service (WINS) name resolution does not complete correctly, or if WINS is not used. Additionally, this issue occurs if the user's domain is not in the suffix search list.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Microsoft Windows XP Professional 64-Bit Edition (Itanium)
   Date         Time   Version           Size     File name     Platform
   ---------------------------------------------------------------------
   12-Jan-2005  03:18  5.1.2600.1618     203,776  Fdeploy.dll   IA-64
   12-Jan-2005  03:21  5.1.2600.1618      68,096  Wfdeploy.dll  x86
Windows XP Service Pack 1, 32-bit versions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   12-Jan-2005  03:21  5.1.2600.1618      68,096  Fdeploy.dll
Windows XP Service Pack 2, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Jan-2005  03:12  5.1.2600.2594      73,728  Fdeploy.dll      
To work around this issue, add the fully qualified domain name (FQDN) of the user's domain to the suffix search order in DNS, or configure WINS to resolve the name of the domain controller.

For more information about how to add the FQDN to the suffix search order in DNS, visit the "Adding Suffixes to Queries" Web page on the Windows XP Resource Kits Web site: http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/Default.asp?url=/resources/documentation/Windows/XP/all/reskit/en-us/prjj_ipa_bneg.asp

For more information about how to configure WINS, visit the "Best practices" Web page on the Windows Server System Web site: http://technet2.microsoft.com/windowsserver/en/library/ED9BEBA0-F998-47D2-8137-A2FC52886ED71033.mspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:6/21/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbfix kbbug KB892227 kbAudITPRO