Users receive a "The user name or password is incorrect" error message if they try to connect to a SBS 2003-based computer by using the Remote Web Workplace feature (892078)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

If a user tries to connect to a Microsoft Windows Small Business Server (SBS) 2003-based computer by using the Remote Web Workplace feature, the user receives the following error message:
The user name or password is incorrect. Verify that CAPS LOCK is not on, and then retype the current user name and password. If you receive this message again, contact your system administrator to ensure that you have the correct permissions to use the Remote Web Workplace.
This symptom occurs if the following conditions are true:
  1. When the user tries to connect, the user receives a prompt to change their password.
  2. The user types the correct original password, types the new password, and then clicks OK.

CAUSE

This problem occurs if the following conditions are true:
  • The user's account has the "User must change password at next logon" feature enabled.
  • The NetBIOS domain name does not match the left side of the DNS domain name. For example, the DNS domain name is "example.local" and the NetBIOS domain name is not "example."
Note This problem also may occur if the user is not a member of the Remote Web Workplace Users group. Before you follow the steps in the "Workaround" section, verify that the user is a member of this group.

WORKAROUND

To work around this problem, do not try to connect to your SBS 2003-based computer by using the Remote Web Workplace feature after you enable the "User must change password at next logon" feature. Instead, use Microsoft Outlook Web Access (OWA) to change the password. To do this, follow these steps:
  1. Create the IISADMPWD virtual directory. To do this, follow these steps:
    1. Start the IIS Microsoft Management Console (MMC) snap-in. To do this, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Right-click the Web site where you want to create the virtual directory, point to New, and then click Virtual Directory.
    3. In the Virtual Directory Creation Wizard, click Next, type IISADMPWD in the Alias box, and then click Next.
    4. In the Path box, type drive where Windows is installed:\windows\system32\inetsrv\iisadmpwd, and then click Next.
    5. Click to select the following check boxes if they are not already selected:
      • Read
      • Run scripts (such as ASP)
    6. Click Next, and then click Finish.
  2. Set the PasswordChangeFlags value to 0 (zero). To do this, follow these steps:
    1. Click Start, click Run, type cmd in the Open box, and then click OK.
    2. Change to the Inetpub\Adminscripts folder.
    3. Type adsutil.vbs, and then press ENTER.

      Note If this is the first time that you have run Adsutil.vbs, you may receive a "This script does not work with WScript" message. Click OK, click Yes to register CScript as the default host for VBScript, and then click OK when you receive the message that states that CScript was registered successfully. Run the Adsutil.vbs command again. Instead of registering CScript, you can prepend cscript to any adsutil.vbs command. For example, cscript adsutil.vbs set w3svc/1/PasswordChangeFlags [value].
    4. Type cscript adsutil.vbs set w3svc/1/passwordchangeflags 0, and then press ENTER.
  3. Change the Application Pool setting of the IISADMPWD virtual directory to ExchangeApplicationPool. To do this, follow these steps:
    1. Start the IIS MMC snap-in. To do this, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Right-click the IISADMPWD virtual directory.
    3. On the Virtual Directory tab, click ExchangeApplicationPool in the Application Pool list, and then click OK.
  4. Download and install the hotfix that is described in the following Microsoft Knowledge Base article:

    833734 FIX: You experience various problems when you use the Password Change pages in IIS 6.0

    1. Start Registry Editor, and then locate the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWeb\OWA

    2. Locate the DisablePassword entry and change its value to 0.
  5. Restart your computer.
  6. Click Start, click Run, type regsvr32 c:\windows\system32\inetsrv\iisadmpwd\iispwchg.dll, and then click OK.

MORE INFORMATION

For more information about how to use the Change Password feature in Outlook Web Access, click the following article number to view the article in the Microsoft Knowledge Base:

297121 Using the Change Password feature with Outlook Web Access


Modification Type:MajorLast Reviewed:5/11/2006
Keywords:kbtshoot kbprb KB892078 kbAudITPRO