FIX: Internet Explorer may unexpectedly quit with an error message in module Mshtml.dll when you try to locate a Web page in Windows XP Service Pack 2 (892052)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)

SYMPTOMS

Internet Explorer may unexpectedly quit with an error message in module Mshtml.dll when you try to locate a Web page. This problem occurs on a Microsoft Windows XP Service Pack 2 (SP2)-based computer. You may receive the following error message:
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.

To see what data this error report contains, click here.
When you view the data in the error report, the report contains an error signature that is similar to one of the following error signatures:
   Application name  Application version  Module name  Module version  Offset
   ----------------------------------------------------------------------------

   Iexplore.exe      6.0.2900.2180        Mshtml.dll   6.0.2900.2180   00052d7d

   Iexplore.exe      6.0.2900.2180        Mshtml.dll   6.0.2900.2523   00052f3d

CAUSE

This problem may occur when a script is run that uses the removeNode function on the Web page.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP Service Pack 2 installed to apply this hotfix.

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes. Additionally, this hotfix is not replaced by any later hotfix.

Registry information

You do not have to create or to modify any registry keys to enable the hotfix that this package contains.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   11-Feb-2005  17:36  6.00.2900.2609  3,008,000  Mshtml.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:5/15/2006
Keywords:kbOCAbucket kberrmsg kbWinXPpreSP3fix kbQFE kbfix kbbug kbHotfixServer KB892052 kbAudEndUser kbAudITPRO