A USB device that is connected to a USB 2.0 hub is not detected in Windows XP Service Pack 2, Windows Server 2003 Service Pack 1, or Windows Server 2003 x64 versions (892050)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

If you connect a new universal serial bus (USB) device to a USB 2.0 hub on a computer, the computer does not detect the USB device. This symptom occurs if the computer is running one of the following operating systems:
  • Microsoft Windows XP Service Pack 2 (SP2)
  • Microsoft Windows Server 2003 Service Pack (SP1)
  • Microsoft Windows Server 2003 x64 versions
Additionally, other USB devices that are already connected to the computer stop functioning, and you have to restart the computer to detect the USB devices.

CAUSE

This problem occurs because the Microsoft USB 2.0 driver causes an Enhanced Host Controller Interface (EHCI) specification violation.

RESOLUTION

Hotfix information for Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires that Windows XP SP2 is installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   31-Mar-2005  01:13  5.1.2600.2644      27,008  Usbehci.sys
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll

Hotfix information for Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires that Windows Server 2003 SP1 is installed on the computer.

Note For Windows Server 2003 x64 versions, no prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, Itanium-based versions

   Date         Time   Version           Size     File name      Platform
   -------------------------------------------------------------------------
   26-Apr-2005  17:11  5.2.3790.2429      89,856  Usbehci.sys
   26-Apr-2005  17:11  6.1.22.4          639,712  Updspapi.dll   IA-64


Windows Server 2003, x64 versions

   Date         Time   Version           Size     File name      
   --------------------------------------------------------------
   26-Apr-2005  17:11  5.2.3790.2429      44,160  Usbehci.sys
   26-Apr-2005  17:11  6.1.22.4          462,560  Updspapi.dll



Windows Server 2003, 32-bit versions

   Date         Time   Version           Size     File name      
   --------------------------------------------------------------
   26-Apr-2005  03:43  5.2.3790.2429      27,520  Usbehci.sys
   05-Mar-2005  01:30  6.1.22.4          371,936  Updspapi.dll




STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbBug kbpubtypekc KB892050 kbAudITPRO