Applications written using the MAPI API as a Windows Service cannot open a personal folders file in Outlook 2003 (891857)



The information in this article applies to:

  • Microsoft Office Outlook 2003

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you have an application that uses the Messaging Application Programming Interface (MAPI) API running as a Windows service to open a personal folders (.pst) file, the MAPI service application may not open the file.

CAUSE

This problem occurs if both the following conditions are true:
  • You are already logged on to the profile that the MAPI application logs on to.
  • You have already opened the personal folders file that the MAPI application tries to open.
This problem can occur if the .pst file has already been opened or it is in use by a different application. If the .pst file is already opened by a user or by a service that is logged on to the Outlook profile, a second MAPI service or a second user cannot open this personal folders file.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.To resolve this problem, follow these steps:
  1. Install the Microsoft Outlook 2003 hotfix package that is described in the following Microsoft Knowledge Base (KB) article:

    885868 Description of the Outlook 2003 hotfix package: September 22, 2004

  2. Set the following registry value to 1:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Options\General

    Value name: AddUserToServiceSecurity
    Value type: REG_DWORD
    Value data: 00000001

    To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry subkey:

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Options\General

    3. Right-click General, point to New, and then click DWORD Value.
    4. In the New Value #1 box, type AddUserToServiceSecurity, and then press ENTER.
    5. Right-click AddUserToServiceSecurity, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
  3. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:3/21/2005
Keywords:kbtshoot kbprb KB891857 kbAudITPRO