Exchange 2003 does not send a second non-delivery report when you send an encrypted message from Lotus Notes to Exchange 2003 by using Exchange Connector for Lotus Notes (891850)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you send an encrypted message from Louts Notes to Microsoft Exchange Server 2003 by using Exchange Connector for Lotus Notes, Exchange 2003 does not send a second non-delivery report (NDR) for the encrypted message. Typically, this problem occurs when the auto-forward feature is configured for the Lotus Notes client.

CAUSE

Exchange 2003 cannot parse messages that are encrypted by Lotus Notes. Therefore, Exchange 2003 sends an NDR to the Lotus Notes client. If the auto-forward feature is configured for the Lotus Notes client, the NDR is returned to Exchange 2003. If Exchange 2003 sends a second NDR in response to the returned NDR, a message loop occurs between Exchange 2003 and the Lotus Notes client.

To avoid this message loop, Exchange 2003 does not send a second NDR. However, if Exchange 2003 does not send a second NDR, the encrypted message that generated the first NDR is lost.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install the hotfix that is described in this section, you must create the DropBadMailIfNotNDR registry entry. If the DropBadMailIfNotNDR value is set to 1, Exchange 2003 routes the NDR to the Exchange.Bad folder of the Lotus Notes server. Depending on the number of NDRs and the size of the NDRs, the hard disk volume of the Lotus Notes server may be affected. You must regularly examine the Exchange.Bad folder and the hard disk volume.

To create and to enable the DropBadMailIfNotNDR registry entry, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then select the following registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LME-NOTES\Parameters\
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DropBadMailIfNotNDR, and then press ENTER.
  5. Right-click DropBadMailIfNotNDR, and then click Modify.
  6. In the Edit DWORD Value dialog box, click Decimal, type 1 in the Value data box, and then click OK.
  7. Quit Registry Editor.
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time    Version       Size     File name
   ---------------------------------------------------------
   27-Jan-2005   21:03   6.5.7232.74   41,984   Lsntsmex.exe     

Prerequisites

Because of file dependencies, this hotfix requires Exchange 2003 Service Pack 1 (SP1). For more information about how to obtain the latest Exchange 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

Microsoft continues to update the tools that support interoperability among Lotus Domino R5 and Lotus Domino 6, Microsoft Exchange Server 2003, and Microsoft Windows Server 2003 Active Directory. The updated tools for Lotus Domino replace the following tools that are included with Exchange Server 2003 and with Microsoft Exchange Server 2003 Service Pack 2:
  • Exchange Connector for Lotus Notes
  • Calendar Connector for Lotus Notes
  • Migration Wizard for Lotus Notes
To obtain these tools and to obtain guidance and additional resources, visit the following Microsoft Web site: These updated tools provide additional functionality and address several issues that customers reported with earlier versions of the tools.

REFERENCES

For more information about the terminology that Microsoft uses for software that is corrected after it is released, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the naming schema for Exchange Server updates, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:4/10/2006
Keywords:kbQFE KBHotfixServer kbexchCOEXISTMIGRATION kbfix kbBug KB891850 kbAudITPRO