FIX: A provider returns a NetLib error when an SQLCA structure is split across two QRYDTA replies (891791)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft Host Integration Server 2000 SP1
  • Microsoft Host Integration Server 2000 SP2


SYMPTOMS

An application may use either the Microsoft Host Integration Server 2000 DB2OLEDB driver or the Microsoft ODBC Driver for DB2 to issue queries against an IBM DB2 database. When it does this, the provider may return an internal network library (NetLib) error. This error occurs when the provider processes an SQL Communication Area (SQLCA) structure that is split across two Query Answer Set Data (QRYDTA) replies. This problem is most likely to occur when the result set that is returned by DB2 contains an SQLCA warning structure at the beginning of each row of data.

The error message that is returned by the application may vary. For example, a Microsoft Visual Basic application may return the following error:
err.number = -2147217900 (80040e14)

CAUSE

This problem occurs because the Host Integration Server 2000 DB2OLEDB driver and the ODBC Driver for DB2 do not correctly handle an SQLCA structure that is split across multiple QRYDTA replies.

WORKAROUND

You may be able to work around this problem by modifying the query to correct the condition that causes the SQLCA warning.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   05-Jan-2005  22:40  5.0.0.1018  311,568  Crtpkg.dll
   05-Jan-2005  22:40  5.0.0.1018  700,688  Db2oledb.dll
   05-Jan-2005  22:40  5.0.0.1018   53,552  Ddmstr.dll
   05-Jan-2005  22:40  5.0.0.1018   78,096  Mseidb2c.dll
   05-Jan-2005  22:40  5.0.0.1018  889,104  Mseidb2d.dll
   05-Jan-2005  22:40  5.0.0.1018   24,848  Mseidpm.dll
   05-Jan-2005  22:40  5.0.0.1018  270,608  Mseidrda.dll
   05-Jan-2005  22:40  5.0.0.1018  147,728  Mseidt.dll
   05-Jan-2005  22:40  5.0.0.1018   65,808  Crtpkg.exe
   05-Jan-2005  22:40  5.0.0.1018   82,192  Ddmserv.exe
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug KB891791 kbAudDeveloper