Discovery data records for SMS 2003 clients may be discarded if the records have already been discovered by a secondary site in an earlier time zone (891584)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

Discovery data records (DDR) for Microsoft Systems Management Server(SMS) 2003 clients may be discarded if the records have already been discovered by a secondary site in an earlier time zone.

For example, assume that a primary SMS site is based in Europe. Secondary SMS sites are located in Asia. At 11 A.M., a DDR is created for a client in Asia. The DDR is processed by its local secondary SMS site and then passed up to the primary SMS site in Europe. When the primary SMS site in Europe runs system discovery at 10 A.M., the primary site identifies the clients in Asia and creates a new DDR. When the Discovery Data Manager at the primary site receives the new DDR, the Discovery Data Manager sees the discovery time of 10 A.M. The Discovery Data Manager concludes that the DDR is older than the 11 A.M. discovery time and discards the DDR.

CAUSE

This problem occurs because the Heartbeat DDR is considered newer than the Active Directory System Group DDR.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

885643 How To obtain the latest Systems Management Server 2003 service pack

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next System Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Baseobj.dll2.50.3174.1162987,13625-Oct-200415:05x86
Smsse.dll2.50.2726.15440,96025-Dec-200314:30x86
Smsse.dll2.50.2726.15440,96025-Dec-200314:30x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbSMSClients kbSMSDiscovery kbpubtypekc KB891584 kbAudITPRO