You receive "A general failure occurred" error message when you click Finish in the New Database Wizard in Microsoft Small Business Customer Manager (891539)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Small Business Customer Manager
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

When you click Finish in the New Database Wizard, you receive the following error message:
A general failure occurred. Close Customer Manager, then try again.

Import cannot complete. Click Ok to go back to the last step of the New Database Wizard.
This problem occurs when you run the New Database Wizard to import your Microsoft Outlook contact information. This problem occurs in Microsoft Small Business Customer Manager.

CAUSE

This problem occurs if all the following conditions are true:
  • You run Small Business Customer Manager on a Windows XP-based computer.
  • You update Microsoft Office 2000 with the Office 2000 security update that is described in the following Microsoft Knowledge Base article:

    For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

    822035 Description of the Office 2000 Security Patch: September 3, 2003

  • You configure a database password when you run the New Database Wizard.

WORKAROUND

To work around this problem, do not configure a database password when you run the New Database Wizard. After you complete the steps of the New Database Wizard, configure a password for your database in Small Business Customer Manager.

Note In this scenario, when you run the New Database Wizard, and you do not configure a password for your database, you receive one or more messages that are similar to the following: A program is trying to access e-mail addresses you have stored in Outlook. Do you want to allow this?

If this is unexpected, it may be a virus and you should choose "No". You must click Yes to let the New Database Wizard import your Outlook contact information.

To configure a password for your Small Business Customer Manager database after you have created that database, follow these steps:
  1. Start Small Business Customer Manager.
  2. On the Tools menu, point to Security, and then click Change Password.
  3. Leave the Old Password box blank. Type a new password in the New Password box, type the same password in the Confirm Password box, and then click OK.

Modification Type:MajorLast Reviewed:1/7/2005
Keywords:kberrmsg kbtshoot kbprb KB891539 kbAudDeveloper