BUG: The ARROW keys and the BACKSPACE key do not work in the keyword lookup box in HTML Help 1.3 (891400)



The information in this article applies to:

  • Microsoft HTML Help 1.3

SYMPTOMS

In Microsoft HTML Help 1.3 viewer, the following keys do not work when you try to change the search string in the Type in the keyword to find box:
  • LEFT ARROW
  • RIGHT ARROW
  • BACKSPACE

CAUSE

This problem occurs when only one tab exists in the left pane of the HTML Help file. The focus for the keys that are listed in the "Symptoms" section remains in the right pane of the HTML Help viewer.

WORKAROUND

To work around this problem, use one of the following methods:
  • Create two tabs in the left pane of the HTML Help file. For example, include a Search tab and a Favorites tab.
  • After the problem occurs, press F6 to reset the focus information for keyboard input.
  • Use the ALT+W keyboard shortcut to change the focus.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. Create an HTML Help file (.chm) that has only one tab, such as the Search tab.
  2. In the left pane, type any word in the Type in the keyword to find box.
  3. Click anywhere in the right pane to change the focus.
  4. In the left pane, click inside the Type in the keyword to find box.
  5. Press the following keys in any order:
    • LEFT ARROW
    • RIGHT ARROW
    • BACKSPACE
Notice that the insertion point does not move, and the characters are not deleted.

Modification Type:MajorLast Reviewed:1/11/2005
Keywords:kbtshoot kbbug KB891400 kbAudDeveloper kbAudITPRO