FIX: A custom application that uses context activation stops responding in Windows XP with Service Pack 1 or Service Pack 2 (891117)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional

SYMPTOMS

In Microsoft Windows XP with Service Pack 1 (SP1) or Service Pack 2 (SP2), when you start a custom application that uses context activation, the application may stop responding (crash).

CAUSE

This problem occurs if the QueryPathOfRegTypeLib function does not correctly return the fully qualified file name for a type library that was specified in the manifest file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version        Size     File name
  --------------------------------------------------------   
  14-Dec-2004  19:31  5.1.2600.2580   65,024  Asycfilt.dll     
  14-Dec-2004  19:31  5.1.2600.2580  549,376  Oleaut32.dll     
  14-Dec-2004  19:31  5.1.2600.2580   83,456  Olepro32.dll     
  14-Dec-2004  00:52  5.1.2600.2580   16,896  Stdole2.tlb
  30-Nov-2004  23:05  2.10.3027.1      7,168  Stdole32.tlb

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the hotfix for Windows XP Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

895322 FIX: A custom program that uses context activation may unexpectedly stop responding on a computer that is running Windows XP with Service Pack 1


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbWinXPsp3fix kbWinXPpreSP3fix kbBug kbfix kbQFE kbHotfixServer KB891117 kbAudITPRO kbAudDeveloper