The Report Server service does not successfully start, and an Error event message is logged in the Application log in SQL Server 2000 Reporting Services (891083)



The information in this article applies to:

  • Microsoft SQL Server 2000 Reporting Services

BUG #: 30742 (Content Maintenance)
BUG #: 113563 (sqlbudt)

SYMPTOMS

The Report Server service (ReportServer) does not successfully start after you do the following:
  1. You install Microsoft SQL Server 2000 Reporting Services so that Reporting Services connects to a remote instance of Microsoft SQL Server.
  2. You install and then remove a local instance of Microsoft SQL Server 2000.
When this problem occurs, an Error event message that is similar to the following is logged in the Application log: Event ID: 0
Type: Error
Source: SQL Server Report Service
Category: None
Description:
Service cannot be started.
Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException: An internal error occurred on the report server.
See the error log for more details. at Microsoft.ReportingServices.Library.ServiceAppDomainController.Start() at Microsoft.ReportingServices.NTService.ReportService.OnStart(String[] args) at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

CAUSE

This problem occurs when you remove SQL Server 2000. When you do this, some registry keys are removed. Therefore, the registry keys that Reporting Services requires to operate are no longer in the registry.

WORKAROUND

To work around this problem, you must reinstall Reporting Services. To do this, follow these steps:
  1. Insert the Reporting Services product CD into the CD drive.
  2. If the Microsoft SQL Server 2000 Reporting Services End User License Agreement page does not appear, run Reporting Services Setup (Setup.exe) on the product CD.
  3. On the Microsoft SQL Server 2000 Reporting Services End User License Agreement page, click to select the I accept the licensing terms and conditions check box, and then click Next.
  4. On the Component Update page, click Next.
  5. On the System Prerequisites Check page, click Next.
  6. On the Change or Remove Instance page, click Change Installed Components.
  7. On the Feature Selection page, click Next.
  8. On the Ready to Update page, click Install.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. Install SQL Server 2000.
  2. Install SQL Server 2000 Service Pack 3a.
  3. Install Reporting Services so that Reporting Services connects to a remote instance of SQL Server.
  4. Remove SQL Server 2000.

REFERENCES

For more information about how to install and how to deploy Reporting Services, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:3/4/2005
Keywords:kbsetup kbtshoot kbprb kbbug KB891083 kbAudDeveloper