FIX: You can only start an SNA trace when you log on as a member of the local Administrators group in Host Integration Server 2004 (891063)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

In Microsoft Host Integration Server 2004, you can only start an SNA trace when you log on as a member of the local Administrators group. You cannot start an SNA trace when you log on as a member of the HIS Administrators group.

CAUSE

The Host Integration Server 2004 SNA Trace Utility (Snatrace.exe) tries to open the service registry keys for the Host Integration Server 2004 services that are installed that have Read and Write permissions. The HIS Administrators group does not have Write permissions to the registry keys. This prevents the SNA trace from being started.

The Host Integration Server 2004 service registry keys include the following registry keys:
  • HKLM\CCS\SYSTEM\CurrentControlSet\Services\<Link Service>\Parameters
  • HKLM\CCS\SYSTEM\CurrentControlSet\Services\SnaServr\Parameters
  • HKLM\CCS\SYSTEM\CurrentControlSet\Services\TN3270\Parameters
  • HKLM\CCS\SYSTEM\CurrentControlSet\Services\SnaBase\Parameters
Additional registry keys may exist depending upon the Host Integration Server 2004 services that are installed.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size    File name
   ----------------------------------------------------
   02-Feb-2005  18:26  6.0.1934.0  99,840  Snatrace.exe
Note Because of file dependencies, the most recent fix that contains this file may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbbug KB891063 kbAudDeveloper