FIX: You may intermittently receive the "SQLSTATE: 08S01, SQLCODE: -605" error message when you perform distributed transactions over TCP/IP by using the OLE DB Provider for DB2 in Host Integration Server 2004 (891062)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

When you perform distributed transactions over TCP/IP by using the OLE DB Provider for DB2 that is included with Microsoft Host Integration Server 2004, you may intermittently receive the following error message:
SQLSTATE: 08S01, SQLCODE: -605
When this problem occurs, the network connection is closed between the system that is using the OLE DB Provider for DB2 and the remote system that is running IBM DB2.

SQLCODE -605 is defined as DB2OLEDB_COMM_SOCKET_REC_FAILED. This error indicates that the OLE DB Provider for DB2 could not receive the data.

CAUSE

This problem occurs when the Host Integration Server TCP/IP Resync service (DRDAResync.exe) receives chained Distributed Data Management (DDM) code points from a remote DB2 system to roll back a failed transaction. The TCP/IP Resync service does not correctly parse chained DDM code points.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -------------------------------------------------------
   18-Dec-2004  23:57  6.0.1923.0  336,384  Drdaresync.exe
Note Because of file dependencies, the most recent hotfix that contains these files may contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbHotfixServer kbQFE kbHIS2004 kbfix kbbug kbpubtypekc KB891062 kbAudDeveloper