SYMPTOMS
When you use Quest Exchange Migration Wizard or Quest Migration Manager to synchronize information from a computer that is running Microsoft Exchange Server 2003, the Microsoft Exchange Information Store service unexpectedly quits. In this scenario, you may experience one or both of the following symptoms:
For the Microsoft Exchange 2000 Server version of this hotfix, see the following Microsoft Knowledge Base article:
892208 The Microsoft Exchange Information Store service unexpectedly quits when you synchronize information from a computer that is running Microsoft Exchange 2000 Server
CAUSE
This problem occurs if the following conditions are true:
- You run a program that uses the IExchangeExportChanges::Synchronize method to retrieve hierarchy changes from a mailbox or from a public folder in Exchange 2003.
Note Quest Exchange Migration Wizard and Quest Migration Manager use this method. The IExchangeExportChanges::Synchronize method is an open interface that we recommend for incremental change synchronization. - The mailbox or public folder contains a folder that is missing some MAPI properties.
This problem may occur in a scenario where a folder is copied to a public folder and then replicated to another Exchange computer. When this folder is replicated, only some of the rules that it contains are replicated to the other Exchange computer. Because this folder is missing certain MAPI properties, the Microsoft Exchange Information Store service does not process the folder correctly. Therefore, when you try to programmatically obtain hierarchy changes from the mailbox or from the public folder where this folder is stored, the Microsoft Exchange Information Store service quits.
Note You may also experience this problem with other programs that use the
IExchangeExportChanges::Synchronize method to synchronize data with Exchange 2003.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
This hotfix requires Exchange Server 2003 Service Pack 1 (SP1).
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993
How to obtain the latest service packs for Exchange Server 2003
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time item in Control Panel.
Date Time Version Size File name
-----------------------------------------------------------
13-Jan-2005 03:44 6.5.7232.68 295,936 Isinteg.exe
13-Jan-2005 03:57 6.5.7232.68 3,261,952 Mdbmsg.dll
08-Oct-2004 02:12 3,304 Redir.asp
13-Jan-2005 04:31 6.5.7232.68 5,166,080 Store.exe