Computer authentication cannot complete successfully when you use a smart card to log on to a wireless network in Windows XP (890937)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Computer authentication cannot be completed successfully when you use a smart card to log on to a wireless network (802.1X). However, user authentication is successful.

CAUSE

This problem occurs because the computer cannot access the computer certificate from the smart card during the computer startup process.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites to install this hotfix.

Restart information

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click to select the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13

  3. After you select the key that is specified in step 3, on the Edit menu, point to New, and then click DWORD Value.
  4. Type UseSoftTokenWithMachineAuthentication, and then press ENTER.
  5. Right-click UseSoftTokenWithMachineAuthentication, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Quit Registry Editor.
Note After you install this hotfix, when you use a smart card as an authentication method, Windows will access the computer certificate from the HKEY_LOCAL_MACHINE hive in the Windows Registry instead of trying to access the certificate from the smart card.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   30-Dec-2004  01:14  5.1.2600.2587  112,640  Rastls.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPpreSP3fix kbfix kbBug KB890937 kbAudEndUser kbAudITPRO