The computer may stop responding upon restart when you try to upgrade from Windows 2000 to Windows Server 2003 if the computer has multiple paths to the system disk (890826)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition

SYMPTOMS

When you upgrade from Microsoft Windows 2000 to Microsoft Windows Server 2003, the computer may stop responding (hang) after you restart for the first time. You experience this problem on computers where there are multiple paths to the system disk.

CAUSE

This problem may occur if the computer uses a high-availability configuration. Such configurations include Storage Area Network (SAN), network-attached storage, Cluster service, and Network Load Balancing (NLB). The problem occurs when the following conditions are true:
  • The system disk becomes unavailable when Partition Manager (PartMgr.sys) disables access to redundant multiple paths.
  • Information about this condition is not communicated to the Windows text mode Setup program (Setupdd.sys).
In this scenario, Setupdd.sys tries to use an incorrect path to connect to the system disk. When Setupdd.sys tries to use this incorrect path, you experience the problem that is described in the "Symptoms" section.

RESOLUTION

To resolve this problem, use integrated Windows installation source files to install Windows Server 2003 Service Pack 1 (SP1). For more information about how to integrate Windows Server 2003 SP1 into the Windows installation source files, click the following article number to view the article in the Microsoft Knowledge Base:

828930 How to integrate software updates into your Windows installation source files

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the"Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:8/12/2005
Keywords:kbQFE KB890826 kbAudITPRO