SYMPTOMS
Consider the following scenario:
- You are using Microsoft Windows 2000-based or Microsoft Windows Server
2003-based domain controllers.
- You are trying to manage a
Group Policy object (GPO) from a Microsoft Windows XP Professional-based computer.
In this scenario, when you edit and then save a
domain GPO for a user rights assignment in Windows XP, an error message that is similar to the following is logged in the Application event log:
Event Type: Warning
Event Source: SceCli
Event Category: None
Event ID: 1202
Description: Security policies are propagated with warning. 0x534: No mapping between account names and security IDs was done.
Please look for more details in TroubleShooting section in Security Help.
Additionally, some of the built-in security identifiers (SIDs) in the Gpttmpl.inf file are converted to Security Account Manager (SAM)
account names. If you edit this GPO on a domain controller, all SAM account
names change to well-known SIDs.
CAUSE
This problem occurs because you use the Windows Server 2003 Administration Tools Pack to maintain security settings on a Windows XP-based computer. When Windows saves the Gpttmpl.inf file, the
built-in accounts are not
saved to the policy as SIDs. Instead, the
Gpttmpl.inf file lists the account names in the Group Policy user interface (UI)
section. Client computers experience this problem if one or more of the
following conditions are true:
- An account does not exist on domain member computers.
- A SAM account name differs from its domain account name.
- The client is running a Multilingual User
Interface Pack (MUI) that uses a different default language than the domain controller.
- A SAM account name was renamed on the
client computers.
RESOLUTION
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Professional with Service Pack 1
Date Time Version Size File name
--------------------------------------------------------------
26-Jan-2005 20:49 5.1.2600.1621 173,568 Scecli.dll
Windows XP Professional with Service Pack 2
Date Time Version Size File name
--------------------------------------------------------------
26-Jan-2005 20:42 5.1.2600.2604 181,248 Scecli.dll