FIX: The Btsntsvc.exe process uses a high amount of CPU resources and an orchestration never finishes in BizTalk Server 2004 (890731)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Service Pack 1
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition

SYMPTOMS

When you run an orchestration in Microsoft BizTalk Server 2004, you may experience the following symptoms:
  • The Btsntsvc.exe process uses a high amount of CPU resources on the computer.
  • The BizTalk Server orchestration never finishes.
In this scenario, BizTalk Server may use up to 100 percent of CPU resource and BizTalk Server may use additional memory until the computer stops responding (hangs).

CAUSE

This problem occurs because under certain conditions, BizTalk Server 2004 may enter a continuous loop when it processes an orchestration.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have BizTalk Server 2004 Rollup Package 1 installed on your computer

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   --------------------------------------------------------------------
   03-Dec-2004  02:09  3.0.5363.0  217,088  Microsoft.xlangs.engine.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/3/2006
Keywords:kbbiztalk2004-2006swept kbBTSOrchestration kbBizTalk2004preSP1fix kbbug kbfix kbHotfixServer kbQFE KB890731 kbAudDeveloper