You receive a "Log File path is invalid" error message when you try to configure logging on a remote Live Communications Server 2005 computer (890677)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2005 Enterprise Edition
  • Microsoft Office Live Communications Server 2005 Standard Edition

SYMPTOMS

When you use the Microsoft Office Live Communications Server 2005 administrative tool to configure logging on a remote Live Communications Server 2005 computer or pool, you may experience one or more of the following symptoms:
  • If you type a UNC path in the Log File Folder box, and then click OK, you receive the following error message:
    Log File path is invalid. Please enter a valid value for Log File path.
  • If you type a local path, such as C:\LogFiles, in the Log File Folder box, and then click OK, you receive the same error message. However, if the same local path exists on the remote computer, the log files are successfully created in that folder on the remote computer. For example, in this scenario, the log files would be created in the C:\LogFiles folder on the remote computer.
  • If you do not have permissions to the remote folder that you configure the log files to be created in, the log files are not successfully created.

    Note To successfully create log files in a remote folder, you must have the following permissions configured:
    • The administrator who configures remote logging must have Read permissions or greater permissions to the remote folder.
    • The service account that the Live Communications Server 2005 computer runs under must have both Read and Change permissions or greater permissions to the remote folder.

CAUSE

This issue occurs because Live Communications Server 2005 does not recognize a UNC path of a remote location if you enter that path from a remote computer. Additionally, if you remotely specify an absolute path, such as C:\LogFiles, the Live Communications Server 2005 computer where you specify this path interprets this path as a local path.

WORKAROUND

To work around this issue, log on to the remote computer, and then enter the UNC path of the remote share location. To do this, follow these steps:
  1. Log on to the computer that you want to configure logging on, and then start the Live Communications Server 2005 administration tool.
  2. Expand your forest, expand Domains, expand your domain, expand Live Communications servers and pools, expand the pool that contains your Live Communications Server 2005 computer, right-click that computer, and then click Properties.
  3. Click the Logging tab, and then click to select the Enable Logging check box if it is not already selected.
  4. In the Log File Folder box, type the UNC path of the folder where you want the log files to be created. For example, type \\servername\sharename.
  5. Click Apply, and then click OK.

MORE INFORMATION

For additional information about how to configure Live Communications Server 2005, see the list of Live Communications Server 2005 deployment resources. To see this list, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:12/2/2004
Keywords:kbprb kbtshoot KB890677 kbAudITPRO