The Request Forwarder may cause high CPU utilization and requests may be blank when you run Application Center 2000 in a cluster environment (890667)



The information in this article applies to:

  • Microsoft Application Center 2000 SP2


SYMPTOMS

When you run Microsoft Application Center 2000 Service Pack 2 (SP2) in a cluster environment, you experience one or both of the following symptoms:
  • The Request Forwarder may cause the Inetinfo.exe process to run at 100 percent CPU utilization.
  • If you have configured Microsoft Internet Information Services (IIS) to use HTTP Compression, a request that is forwarded by the Request Forwarder may be blank in Microsoft Internet Explorer on a client computer.

CAUSE

This problem occurs because the Request Forwarder does not correctly process the chunked HTTP responses.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Application Center 2000 SP2 before you apply this hotfix.

Restart requirement

You must stop and then restart the IIS Admin Service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Dec-2004  14:04  1.0.781.11        168,960  Rffilext.dll 

WORKAROUND

If you do not use the Request Forwarder, you can disable it.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

262674 How to remove the Request Forwarder ISAPI

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbClustering kbClientProtocols kbClient kbPerformance kbfix KB890667 kbAudITPRO